TiledBackground and saving projects

Bugs will be moved here once resolved.

Post » Fri Sep 02, 2011 11:28 am

C2 r53; Windows XP SP3; FireFox 6.0.1; ATI Radeon HD 4870

I saved a project from a single file to a folder project.
I tried to preview my project and got this check failure:

[code]---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Cannot find file on disk to return over HTTP

Condition: FileExists(disk_path)
File: HttpFileServer.cpp
Line: 278
Function: void __thiscall HttpFileServer::ServerRespond(struct _HTTP_REQUEST_V2 *)
Build: release 53 (32-bit) checked
Component: HTML5 exporter
(Last Win32 error: 2)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abandonner   Recommencer   Ignorer   
---------------------------
[/code]

Looks like the local file server blew off with inexisting file, I'm kinda getting used to it.

Anyway, I exit C2, launch it again, try to open my folder project and now I get an error how my project is missing the object texture for the tiled background object.
A little workaround later, I copy my file (named "BGforest.png") in the textures folder and I am then able to open the project folder.

Like for audio files during r50, it seems that background textures don't get copied correctly from a save to another. (or at least from a single file to a folder project)
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791

Post » Fri Sep 02, 2011 1:20 pm

I can't seem to reproduce this. I opened the Ghost Shooter tutorial .capx (which has a tiled background), and saved as a project. Running it after was fine, and the tiled background's image file was correctly copied to the project folder.

Does opening a project and saving like that reproduce it for you or had you edited the project before that happened?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Fri Sep 02, 2011 1:32 pm

The project was something I had been working on in the previous days.
I had a two days old capx file, opened it, made a new capx save.
Worked a bit on the capx and decided to switch to a folder project.

I can't reproduce it even now with the "originals" capx. It seems to happen after having executed C2 a while, or maybe some other trigger I can't seem to find now.Kyatric2011-09-02 13:32:59
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests