TiledBackground Collision Poligon

Bugs will be moved here once resolved.

Post » Mon Dec 08, 2014 9:36 pm

Problem Description
The collision poligon that is shown for some tiled Backgrounds are weird...

Attach a Capx


Description of Capx
The game works fine, but there is this weird collision poligon in some of my tiled backgrounds, that are shown in the editors mode with colliders on.

THE PROBLEM IS WHEN LOADED. Once the project is saved and reopened the problem is solved.

Steps to Reproduce Bug
  • Create a tiledbackground
  • Open a .png with transparent parts
  • Save and change the tiledbackground with other .png with different transparent parts

Observed Result
In the editors mode the tiled background creates a collision poligon very weird.

Expected Result
Bounding box in every tiled background


Operating System and Service Pack
Windows 7 SP1

Construct 2 Version ID
BETA 191
You do not have the required permissions to view the files attached to this post.
Last edited by kingpirux on Thu Dec 11, 2014 7:34 pm, edited 1 time in total.
B
22
S
4
Posts: 107
Reputation: 1,362

Post » Mon Dec 08, 2014 10:49 pm

So just change the polygon manually. Do you know how?
ImageImageImageImageImage
B
19
S
5
G
1
Posts: 614
Reputation: 2,542

Post » Mon Dec 08, 2014 10:56 pm

Um, there is no collision polygon for tiled bg, its just whatever size the object is.
Image ImageImage
B
171
S
50
G
180
Posts: 8,397
Reputation: 113,988

Post » Mon Dec 08, 2014 11:04 pm

@newt good point, lol.
ImageImageImageImageImage
B
19
S
5
G
1
Posts: 614
Reputation: 2,542

Post » Mon Dec 08, 2014 11:05 pm

It might be worth taking a screenshot and attaching a capx. So we can see what you mean by weird.
ImageImageImageImageImage
B
19
S
5
G
1
Posts: 614
Reputation: 2,542

Post » Tue Dec 09, 2014 7:03 pm

Closing, please attach a .capx and provide screenshots to demonstrate what you mean, or we cannot investigate the report. Please refer to the bug report guidelines for more information.
Scirra Founder
B
400
S
237
G
89
Posts: 24,550
Reputation: 195,537

Post » Thu Dec 11, 2014 7:35 pm

i uploaded screenshots since if you reopen the capx it's fixed :P
B
22
S
4
Posts: 107
Reputation: 1,362


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest