Tilemap asJSON bug in r152

Bugs will be moved here once resolved.

Post » Sun Dec 01, 2013 11:36 pm

Link to .capx file (required!):
https://drive.google.com/file/d/0B36MEu5Qi6YvRlFmU1NDMWoxZGM/edit?usp=sharing

Steps to reproduce:
1. Create tileset A and tileset B, both of which use the same set of tiles. Add some tiles into tileset A, but leave B empty.
2. Save A's AsJSON component to a string, then destroy A.
3. Use B's SetFromJson action on the string that you saved.

Observed result:

The last column of tiles in the tileset is missing from B.

Expected result:

B should show the exact same tiles as A used to show.

Browsers affected:
Chrome: yes
Node-Webkit: yes

Operating system & service pack:

Windows 7 64-bit

Construct 2 version:
    
r152Squidget2013-12-01 23:37:42
B
7
S
1
Posts: 45
Reputation: 1,315

Post » Mon Dec 02, 2013 12:23 am

Did a bit of further testing. Each time I save and load the tilemap through the asJSON function, it cuts off the right edge of each rectangular grouping of tiles, regardless of the position of the tiles in the tilemap. It only triggers when I re-save the string each time with the new tilemap, so it's likely some problem in the format in which the string is saved.
B
7
S
1
Posts: 45
Reputation: 1,315

Post » Fri Dec 06, 2013 2:13 pm

Ah, thanks for the find - should be fixed in the next build.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest