Tilemap collision performance problem

Get help using Construct 2

Post » Mon Jul 18, 2016 10:20 pm

Hey :|

I'm making a sandbox game and I have some weird performance problem ...

when I am at certain place I lost a lot of fps and I think its due to collision check :

No Fps Problem:

Image

Fps Problem:

Image

Thanks. :?
My Twitter:

@Sirvoidd

My Tutorial:

Multiplayer with Photon
B
32
S
12
G
9
Posts: 73
Reputation: 7,089

Post » Tue Jul 19, 2016 2:32 am

That is a big difference in collision checks so could be because of that—have you identified what is causing that significant difference?
ImageImageImage
B
40
S
23
G
11
Posts: 498
Reputation: 10,062

Post » Tue Jul 19, 2016 2:55 am

No I checked everything but I don't understand why I have this difference.
I'm only a bit higer and I lose 50 fps..

I lose fps at the same places.
My Twitter:

@Sirvoidd

My Tutorial:

Multiplayer with Photon
B
32
S
12
G
9
Posts: 73
Reputation: 7,089

Post » Tue Jul 19, 2016 5:36 pm

Sirvoid wrote:No I checked everything but I don't understand why I have this difference.
I'm only a bit higer and I lose 50 fps..

I lose fps at the same places.


I would filter your event sheet for "collision" and/or "overlapping" and see all your events involving those. See if there are things you are constantly checking for that you don't need to
ImageImageImage
B
40
S
23
G
11
Posts: 498
Reputation: 10,062

Post » Tue Jul 19, 2016 6:18 pm

I find the problem ...

It was a useless line of sight with a too big range ^^'

Thanks for the help ^^
My Twitter:

@Sirvoidd

My Tutorial:

Multiplayer with Photon
B
32
S
12
G
9
Posts: 73
Reputation: 7,089


Return to How do I....?

Who is online

Users browsing this forum: divsyntax, volumetv and 7 guests