Tilemap objects slowing down my game

Get help using Construct 2

Post » Mon Apr 25, 2016 12:45 pm

Hi all,

As placeholders I was using Tiled Backgrounds to design the "floors" of my top-down shooter. I have recently re-designed my "floors" using a tilemap object (400px by 320px sliced into 16x16) with no Behaviours. This first tilemap covers the ENTIRE layout as it is functioning as a replacement for the tiled backgrounds. I also have a second tilemap of the same resolution and slice (16x16) on top of the other tilemap, used for detailing (placing items in rooms, for example).

Now whenever I load my game on Android I've lost about 20FPS. I've tried various troubleshooting guides / best practices with Tilemaps from the forums / help pages, but to no avail.

My only option seems to be re-creating 5-10 backgrounds, and having many individual sprites, to cover having some basic detail to my levels. Surely it isn't meant to be this way?
B
8
S
2
Posts: 59
Reputation: 686

Post » Mon Apr 25, 2016 12:55 pm

I can get my 50-60 FPS back by simply deleting the tilemaps *
B
8
S
2
Posts: 59
Reputation: 686

Post » Sat May 07, 2016 9:11 pm

Same problem here, can't find answers... :( Think that its good for graphic memory usage when having complex tiles, but worthless for any collision testing. And even so...
B
6
S
3
Posts: 16
Reputation: 632

Post » Sun May 08, 2016 7:18 am

In order for this to be properly investigated, post a simple .capx that highlights the problem and we can then test it on our systems.
Otherwise, it could just as easily be a mistake in the way you are using the Tilemap object or in your Events somewhere.

If we can corroborate your findings, then it would be a good idea to post a full bug report for Ashley to investigate.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
84
Posts: 5,386
Reputation: 58,454


Return to How do I....?

Who is online

Users browsing this forum: NumberOne and 9 guests