Tilemap Render 'Bleed' Issue + tilemap crash IE/FF

Bugs will be moved here once resolved.

Post » Tue Jan 21, 2014 3:35 pm

Link to .capx file (required! If link is blocked remove the http and www parts):
https://dl.dropboxusercontent.com/u/919275/C2%20Caps/TilemapXRenderIssue.capx

Steps to reproduce:
1. Look at the bits that are rendering improperly, for starters.
2. Set 'Tile X offset' to -2.
3. Observe issues with tiles completely changing and issues with tiles on the left edge of the tilemap during runtime.

Observed result:
In the shot below, you see certain tiles 'bleeding in' to the tiles that are on the left. Note that this is a 32*32 tilemap that is arranged properly. In the tilemap editor, the selection box even covers the bits of the tilemap that it shouldn't cover.



When the tile offset is adjusted to compensate, this causes 'gaps' between tiles on the left side of the tileset and the tiles they're next to, and it completely scrambles the tileset for no particular reason.

With offset on a negative value, Firefox and IE gets a javascript error:

"Javascript error!
IndexSizeError: Index or size is negative or greater than the allowed amount
http://localhost:50001/Tilemap_plugin.js, line 315 (col undefined)

This is either a bug in Construct 2 or a problem in a third party plugin or behavior - please report it to the developer!"

Expected result:
The tilemap not rendering the tiles improperly, really. Also, no javascript error.

Browsers affected:
Chrome: Yes
Firefox: Yes
Internet Explorer: Yes

Operating system & service pack:
Windows 8.1 64bit

Construct 2 version:
    158.2
B
94
S
37
G
11
Posts: 404
Reputation: 11,275

Post » Tue Jan 21, 2014 7:23 pm

That's not rendering bug. Your tileset is somehow damaged, it's not even 32-pix wide (Should be 768, not 766)

I have no idea where you got that one.. Try this instead.
http://opengameart.org/sites/default/files/alien-planet-tileset.png
Need help? Upload .capx file with your question.
B
16
S
4
G
2
Posts: 233
Reputation: 2,560

Post » Fri Jan 24, 2014 5:36 pm

Yeah, the tilemap image is not correctly aligned to a 32x32 grid. For example the cell at (5, 0) clearly starts at X = 126 instead of 128, so you'll get two pixels of bleed there.

I can't reproduce that JS error even with a negative offset, can you make a .capx that does it straight away?
Scirra Founder
B
395
S
231
G
88
Posts: 24,367
Reputation: 193,694


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest