Tilemap tile collisions broken in r152?

Discussion and feedback on Construct 2

Post » Sun Dec 01, 2013 11:42 pm

@Zantium - the .capx you provided does not actually test any collisions. You should provide a .capx which actually demonstrates the problems you're seeing.
Scirra Founder
B
387
S
230
G
87
Posts: 24,248
Reputation: 192,226

Post » Mon Dec 02, 2013 12:44 am

@Ashley - no problem, I've stripped a lot of the assets out and put a tilemap below where the rocket starts with a few tiles in place. You can see the rocket cannot pass through the tilemap object area.

https://www.dropbox.com/s/nhj1df1taa0zodj/Asteroid%20Lander%200.7%20tilemap.capx

Numpad keys to control - 4=rotate left, 6=rotate right, 8=major thrust, 5=minor thrust.
B
14
S
3
G
2
Posts: 59
Reputation: 2,180

Post » Mon Dec 02, 2013 8:49 am

@Zantium Saving your a lot of time... you should have told them you're discovering a bug about "Physic" behavior with collision conflicts transparent tiles.


@Ashley yep I confirm this is a bug, using Physic with Immovable option causes empty tiles are active collision.Joannesalfa2013-12-02 08:52:23
B
97
S
35
G
29
Posts: 3,139
Reputation: 28,361

Post » Mon Dec 02, 2013 12:44 pm

[QUOTE=Joannesalfa] @Zantium Saving your a lot of time... you should have told them you're discovering a bug about "Physic" behavior with collision conflicts transparent tiles.
[/QUOTE]
@Joannesalfa I did in my 3rd post. Until then I didn't know it was just with physics enabled objects (and it's the same whether it's immovable or not) as I thought I was missing something and didn't know that the collision box view didn't work as it appeared to work in Ashley's blog.
Once I knew that the collision box view was a red herring then I was able to pinpoint the problem further.
B
14
S
3
G
2
Posts: 59
Reputation: 2,180

Post » Tue Dec 03, 2013 2:04 am

@Zantium the problem is Physic behavior isn't compatible with Tilemap collision.

Could you file this bug in Bugs section?
B
97
S
35
G
29
Posts: 3,139
Reputation: 28,361

Post » Tue Dec 03, 2013 2:15 am

B
97
S
35
G
29
Posts: 3,139
Reputation: 28,361

Post » Fri Dec 06, 2013 11:49 am

@Joannesalfa Thanks for doing the bug report, I've been away and offline for a few days - just logged back in to do the same thing. :)
B
14
S
3
G
2
Posts: 59
Reputation: 2,180

Post » Sat Dec 07, 2013 12:07 am

@Zantium your welcome!
B
97
S
35
G
29
Posts: 3,139
Reputation: 28,361

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: Bobbyneal100, DomenicS, troxx and 5 guests