Tilemap Unresponsive Script

Report Construct 2 bugs here.

Post » Sun Jul 16, 2017 7:50 pm

Problem Description
Loading layouts with a 2048x2048 Tilemap in them causes Unresponsive script error (tilemap_plugin.js or glwrap.js) in Firefox and noticeable delay in other browsers (Chrome/Edge/IE). Game will eventually run on Firefox as well if the script is continued despite warnings. Changing the source image did not affect the issue.

This issue also persists after the project has been exported and my friend reported the same error when playing my game on Firefox.

I thought there might be something wrong in the Tilemap-plugin so I tried reinstalling C2 and installed r245 Beta but it didn't solve the issue.

Image
http://imgur.com/a/rtbsa

Attach a Capx
https://drive.google.com/drive/folders/ ... WpBalpjWWs

Description of Capx
2 Layouts, other one has a Tilemap in it and other doesn't.

Steps to Reproduce Bug
Open the Capx file. Run the layout with a Tilemap in Firefox.

Observed Result
Tilemap script is unresponsive (error in Firefox, delay in other browsers)

Expected Result
No errors, no noticeable delay.

Affected Browsers
  • Chrome: NO (or partially)
  • FireFox: YES
  • Edge: partially
  • Internet Explorer: NO (or partially)

Operating System and Service Pack
Windows 10

Construct 2 Version ID
r244 & r245 (beta)
"If you don't build your dream, someone else will hire you to build theirs"
B
12
S
3
G
1
Posts: 57
Reputation: 913

Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests