today scirra signalling server

Discussion and feedback on Construct 2

Post » Sat Feb 28, 2015 12:02 pm

hello,
have someone else also problem with sync objects with signalling server today?
objects disappear/appear uncommon.
B
8
S
3
Posts: 63
Reputation: 736

Post » Sat Feb 28, 2015 2:29 pm

I checked and the signalling server is running fine today (I had to reboot it for a Windows Update though so it was down for 1-2 min). Besides if you read the multiplayer tutorial you'll see that the signalling server is not involved in syncing objects, that is done by the room host.
Scirra Founder
B
378
S
220
G
84
Posts: 23,863
Reputation: 188,019

Post » Sat Feb 28, 2015 3:17 pm

hi ashley, thank you for your response,
as you said, about multiplayer tutorial, now i remember me.
eventualities, my part or the beta update yesterday or anything else ...
B
8
S
3
Posts: 63
Reputation: 736

Post » Sat Feb 28, 2015 4:58 pm

after testing it seems the reason is 99% the r198 beta.
objects disappear/appear/... happens only at multiplayer client side.
B
8
S
3
Posts: 63
Reputation: 736

Post » Sun Mar 01, 2015 11:37 am

We haven't made any changes at all to the multiplayer engine for quite some time now, so it would be strange. Are you sure it's not your connection?
Scirra Founder
B
378
S
220
G
84
Posts: 23,863
Reputation: 188,019

Post » Sun Mar 01, 2015 12:44 pm

i think it not belongs the connection.
if me change to other tab, and switch back the sprites appear and then they disappear again.
i make a new screen video for it ...
Last edited by MarkusR on Sun Mar 01, 2015 1:00 pm, edited 1 time in total.
B
8
S
3
Posts: 63
Reputation: 736

Post » Sun Mar 01, 2015 12:56 pm

here a short screen video, its better than every explanation.
look at the tab changes.
for the gaming pieces i used sync object.
http://youtu.be/vZKs1CUH1zk

for other reader,
r197 was fine, i tested always within tabs.
pause on unfocus = no (problem happens also in open tab)
i think i used at all multipleayer event a log entry.
i did NOT hide or show this gaming pieces in any way.

some new info: if the game runs in seperate browser window everything is ok...
(did not mean it is solved)
same issue in firefox and chrome browser ...

the gaming pieces also get invisible at client if the host window go minimized
and reappear at client if host window goto normal state.
that is not wrote in manual. also not expected. (not saw a event Multiplayer.Inactive/Activate)
if opponent minimized his window or change tab all sprites disappear unwanted at client side.
B
8
S
3
Posts: 63
Reputation: 736


Return to Construct 2 General

Who is online

Users browsing this forum: papadale, SnipG and 9 guests

cron