Touch Plugin is Broken with Blackberry 10?

Discussion and feedback on Construct 2

Post » Fri Aug 30, 2013 1:39 pm

Hi, I have been testing several games we've made with C2 on the latest Blackberry 10 Simulator, using the latest Webworks SDK, for only the Blacberry Z10 touch screen phone.

We've found the following issues:

When we included the touch plugin in the game:

1) The JS side of the page fails to load in the simulator.
2) There is a blank area where the canvas is supposed to be.
3) The rest of the page does load (plain html)
4) We enabled Blackberry's debug tools (web inspector on compile) and the tool does not even load at this stage (no pop up with the IP address). Therefore we cant even debug it on the simulator.
5) Everything works 100% in Chrome browser, however.

This happens every time with a game we created, as well as Construct 2's own examples (particularly the "Space Blaster" example.


After 10 hours of debugging and reinstalling all Blackberry packages and trying to figure out whats going on, we then removed the Touch plugin from the project and for all games, including C2's own provided examples, the game did load perfectly, as well as the web inspector debug tool (pop up with IP address).


Is anyone else having this issue? I first thought it was a logic problem inside my capx but then tried it with C2's own "Space Blaster" game and the same thing happened.

But since it worked 100% in Chrome, we decided it might've been a Simulator issue. We went ahead and submitted the app to Blackberry anyways. 48hrs later we received an email back from the app reviewer saying he is unable to push any buttons on the screen, suggesting the touch functionality is broken.

please help.
bbgaming2013-08-30 13:49:22
B
1
Posts: 1
Reputation: 127

Post » Sat Aug 31, 2013 1:15 am

I have a Blackberry Z10 touch, would you send me a .bar?
B
99
S
35
G
29
Posts: 3,139
Reputation: 28,421


Return to Construct 2 General

Who is online

Users browsing this forum: sunisa2532, Yahoo [Bot] and 18 guests