Troubling Errors from Debugger

For questions about using Classic.

Post » Wed Dec 29, 2010 11:26 pm

I get some errors when messing with grenades.

EDIT: Whoops, images go out of the thread. Right click and click "View image" to get the whole thing.

I forgot how this one was generated:



But THIS one ALWAYS triggers when exactly 58 grenades explode. At the same time or individually.



And, just to let you know, there is NOTHING relating to grenades in the AI Event sheet. I don't know why it is saying that. :\

Here is a cap (Outdated, but has the same errors): http://www.mediafire.com/?ar0hhprqscyhhwn
B
26
S
7
G
5
Posts: 202
Reputation: 5,235

Post » Thu Dec 30, 2010 3:12 am

This is indeed VERY strange. I got a different error to you:

As you can see my error points to object_player_arms, at event 0 on the AI event sheet. So maybe the issue lies somewhere in the event sheet itself and not with a specific object? There isn't even an "Event 0" :?.

Sorry i can't really help more than that, this one has me stumped, but maybe it will guide you in the right direction on where to look for the problem :D.

Edit:
I decided to test it some more and disabled the AI event sheet, and got this error:

So maybe its not the AI event sheet at all. I also tried toggling different events on and off in all sorts of different combinations and NOTHING seems fix it :(.

I'm sure it will turn out to be something simple though :roll:
B
7
S
2
G
4
Posts: 164
Reputation: 2,418

Post » Thu Dec 30, 2010 4:22 am

[quote="Citnarf":1pt1rs4f]This is indeed VERY strange. I got a different error to you:

As you can see my error points to object_player_arms, at event 0 on the AI event sheet. So maybe the issue lies somewhere in the event sheet itself and not with a specific object? There isn't even an "Event 0" :?.

Sorry i can't really help more than that, this one has me stumped, but maybe it will guide you in the right direction on where to look for the problem :D.

Edit:
I decided to test it some more and disabled the AI event sheet, and got this error:

So maybe its not the AI event sheet at all. I also tried toggling different events on and off in all sorts of different combinations and NOTHING seems fix it :(.

I'm sure it will turn out to be something simple though :roll:[/quote:1pt1rs4f]

I guess my version of construct is HAUNTED.

OooOOOoOoOoooOooOOOOOoooOOOOOOOOOO!!!!


EDIT: On a related note, I would REALLY like to know where that huge ass number came from. :?
B
26
S
7
G
5
Posts: 202
Reputation: 5,235

Post » Thu Dec 30, 2010 11:36 am

It's that enable scripting bug, uncheck it and the crash will be eliminated.
B
79
S
24
G
54
Posts: 4,740
Reputation: 40,743

Post » Thu Dec 30, 2010 3:24 pm

[quote="R0J0hound":1cj1pwu0]It's that enable scripting bug, uncheck it and the crash will be eliminated.[/quote:1cj1pwu0]

...I feel really stupid right now...
B
26
S
7
G
5
Posts: 202
Reputation: 5,235

Post » Thu Dec 30, 2010 4:07 pm

Woah i thought it would be something simple, but not THAT simple :|
B
7
S
2
G
4
Posts: 164
Reputation: 2,418


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 6 guests