Turn off WebGL in Awesomium

Get help using Construct 2

Post » Fri Dec 28, 2012 6:12 pm

Hello,

Is there any way to turn off WebGL in Awesomium?

I'm sure most people want to turn it on, but for my case I'm using the Canvas plugin, which has performance issues when WebGL is on.


Thanks,
Cym
B
16
S
1
G
3
Posts: 43
Reputation: 2,597

Post » Fri Dec 28, 2012 6:25 pm

You can disable WebGL in your project's configuration settings inside Construct 2.
B
27
S
8
G
8
Posts: 903
Reputation: 8,452

Post » Fri Dec 28, 2012 6:43 pm

Thank you. I should have pointed out that I have disabled WebGL in my project. But I believe the Awesomium export automatically enables it by default. Which is intentional. I'm curious if there is a way around that, including editing any of the Awesomium files if needed.
B
16
S
1
G
3
Posts: 43
Reputation: 2,597

Post » Fri Dec 28, 2012 7:12 pm

Yeah, I suspected you had already tried changing the settings, but I thought I'd mention it just in case.

I haven't tested Awesomium properly myself so I didn't know it ignored the setting. There's probably a reason for forcing WebGL though, so I doubt it can be changed at this moment. Maybe in a future release.

B
27
S
8
G
8
Posts: 903
Reputation: 8,452

Post » Thu Jan 10, 2013 3:12 pm

With WebGL ON exporting with Awesomium I noticed a weird fps, but when turning WebGL OFF now works properly with high fps. Try it now, I don't know if they did modify anything from 28th of December to today but I'm getting better fps's.
B
17
S
4
G
4
Posts: 104
Reputation: 3,950


Return to How do I....?

Who is online

Users browsing this forum: Bad Wolf, davides, NRABrazil, Vallar, WhosWho and 26 guests