Turret+WP8: some enemies are frozen on creation

Bugs will be moved here once resolved.

Post » Tue Dec 31, 2013 3:51 pm

Link to .capx file (required!):
https://skydrive.live.com/redir?resid=DA0992CEC3A785CF!509&authkey=!APRcZYbxs45cOXQ&ithint=file%2c.capx

Steps to reproduce:
1. Just run the game on a Windows Phone 8 device
2. Wait until the enemies start being created faster

Observed result:
It is just your Turrent sample, with no changes.
After some time, the enemies start behaving weird, like they are lost and, after some time, they get a clue and start walking, but stacked on others enemies.
The issue does not occur on iPad.
I have tested it deploying via Intel XDK.


Expected result:
The enemies would walk near every other, just changing the 0.01s, according the built-in rule in the game, until the predefined limit.


Browsers affected:
Chrome: I dont know
Firefox (desktop): no - works good
Internet Explorer (desktop): no - works good
Internet Explorer (mobile): YES - the problem is here

Operating system & service pack:
Windows Phone 8

Construct 2 version:
Release 152 64 bits
Nov 29 2013    
B
3
Posts: 2
Reputation: 179

Post » Tue Dec 31, 2013 4:12 pm

Also, the enemies seems to be killed faster on Windows Phone 8.

I noticed that because, in iPad, I need to set way more towers to defeat the hordes.

Maybe because when the enemies are stacked (WP8), they all receive the bullet at the same time? Just speculating.
B
3
Posts: 2
Reputation: 179

Post » Mon Jan 06, 2014 12:44 pm

Can't reproduce on a Nokia Lumia 820, runs just fine. By the way the example is modified: it has changes to support different kinds of bullet.
Scirra Founder
B
398
S
236
G
88
Posts: 24,439
Reputation: 194,647


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests