Tutorial: Platform School

Post your own tutorials, guides and demos.

Post » Sat Jan 31, 2009 12:41 pm

Are you ready? Bonesaw is ready!

And the next lesson is ready, too!

[list:2ekziz7m][*:2ekziz7m][url=http://www.scirra.com/phpBB3/viewtopic.php?f=8&t=2154[/url]
[list:2ekziz7m]
Creating two more advanced custom controls for swimming and climbing ladders.
[/list:u:2ekziz7m][/*:m:2ekziz7m][/list:u:2ekziz7m]

The last one was a piece of cake. This one gets a little more complicated. There's nothing really all that new, it's just more of the same, using all the basic ideas learned from prior lessons. Just, you know, taking it to the next step, so to speak.

Oh, and for anyone that cares, I had to redo all the previous lessons to correct a mistake (that I had no knowledge of until yesterday) so if you want to, go ahead and re-download them. It's not really necessary, though... it just has to do with renaming your controls. Short answer: Don't rename the default controls if you're using a behavior that uses controls for input.

Also, I'll get those text files for the signs up some time soon.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Sat Jan 31, 2009 1:08 pm

Brilliant :) One thing though - the moving platform at the top of the first ladders doesn't seem to move - it goes like one pixel every 5 seconds or something. I had to wait ages before I could clear the jump.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Sat Jan 31, 2009 1:13 pm

Uh... what? It shouldn't, it just has Bullet behavior on it, nothing special. The speed is set to 50. It should take a couple of seconds to cross the gap, not a couple of seconds per pixel...

It's working fine for me. And Rich and Sslaxx both tested it and said everything looked fine. Is that happening for anyone else?
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Sat Jan 31, 2009 1:17 pm

Just tried again, it works now... probably a Construct bug :P
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Sat Jan 31, 2009 2:22 pm

Can't wait until the next lesson! Enemy AI should be interesting.

How many lessons are you planning on making? Well, anyway, I find your tutorials to be really informative and the first few really helped me with my projects.

Thank you for the superb tutorials :D
B
2
S
2
G
3
Posts: 143
Reputation: 1,536

Post » Sat Jan 31, 2009 8:46 pm

Thanks for this thread, I learned a TON in just 2 days by analyzing your scenes! :)
B
6
S
2
G
3
Posts: 520
Reputation: 2,690

Post » Sun Feb 01, 2009 1:12 am

Thanks for the new lesson, awesome!
B
2
G
3
Posts: 24
Reputation: 898

Post » Sun Feb 01, 2009 1:30 am

I have a little question:

Why do you set you ground sprites to invisible in the start of layout event, but use the 'invisible on start' attribute for your player sprite?
B
2
S
2
G
3
Posts: 105
Reputation: 1,510

Post » Sun Feb 01, 2009 2:03 am

Edit:
Oops! I read your post wrong :P

Edit 2:
Oops! I gave the wrong answer to the right question :P

It's because Tiled Backgrounds don't have any "Appearance" settings in the properties.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Sun Feb 01, 2009 2:38 am

Ah, that makes sense now. I hadn't used tileable backgrounds in mine, just sprites (not very efficient). I didn't look at yours so closely, and I hadn't really registered the full scale of the differences between sprites and tiles until now. It doesn't actually say anywhere in the interface - "Sprite" - when you select a sprite, or whatever. Looking closely I can see how much difference there is between the two.
B
2
S
2
G
3
Posts: 105
Reputation: 1,510

PreviousNext

Return to Your tutorials & example files

Who is online

Users browsing this forum: No registered users and 0 guests