Two Node-webkit problems still on v.168 [Temp Freeze fix!]

Discussion and feedback on Construct 2

Post » Sun Feb 16, 2014 12:40 pm

Would like to know if others are having these issues.

First is the freezing issue. Like on THIS VIDEO at 1:43. That is quite short but it can be longer and usually is about 4-6 sec.

Second issue is with some Blend modes. If you download THIS example and you try it in browser (tested Firefox and Chrome) it works as intended, but on Node-webkit it doesn't work if WebGL is enabled just shows black. Should be that blue background with some white lines.

Im using C2 version 168 64-bit

Could these be bugs or something else.

For anyone who's suffering from NWK freezes after exporting, try reverting back to 0.8.6, as it is working for us.

LINK:
https://github.com/rogerwang/node-webkit
Under downloads, Prebuilt binaries (v0.8.6 - Apr 18, 2014): win32

Remove your game.exe, extract the file to your node-webkit exported project (replace remaining files ), and that's it! You can rename the exe file.
Last edited by Katala on Wed Aug 20, 2014 3:36 pm, edited 6 times in total.
B
34
S
9
G
3
Posts: 517
Reputation: 5,246

Post » Sun Feb 16, 2014 1:54 pm

I've noticed freezes recently in r161 as well, but couldn't be sure if it was related to Node-Webkit or something else.
Sometimes using preview or export game can freeze at the beginning. But after closing and restarting every thing works fine.
ImageImageImageImage
B
158
S
66
G
43
Posts: 2,603
Reputation: 35,868

Post » Sun Feb 16, 2014 4:38 pm

I also made simple example where there is just a box with physics behavior falling down and it's then destoyed and spawns a new one. This is also doing the same thing.
B
34
S
9
G
3
Posts: 517
Reputation: 5,246

Post » Mon Feb 17, 2014 9:51 am

I sometimes also have freezes like that. I though it was an issue with my code (a memory leak or something). I haven't realize it could come from a Node-Webkit bug.
So this topic interests me!
B
72
S
21
G
12
Posts: 314
Reputation: 12,121

Post » Mon Feb 17, 2014 5:22 pm

I also made just very simple box falling experiment and it does the same thing.
B
34
S
9
G
3
Posts: 517
Reputation: 5,246

Post » Mon Feb 17, 2014 5:42 pm

I'm not sure why node-webkit shows a black background, but it's related to the layer's destination-atop blend mode. If you change that it works OK.
Scirra Founder
B
399
S
236
G
89
Posts: 24,519
Reputation: 195,361

Post » Mon Feb 17, 2014 6:53 pm

@Ashley, I was messing with the blend modes for the effect that the light draws over player but not the background.

Is there another way to make that effect for Node-webkit.
B
34
S
9
G
3
Posts: 517
Reputation: 5,246

Post » Fri Mar 28, 2014 1:42 pm

@Ashley, the freeze that I told you is exact the same in the @Katala 's game. I noticed that the engine also have a memory leak and it could have something to do about it.

@Katala did you fix it? I tried many things, but the freezing is still there.
B
13
S
2
Posts: 104
Reputation: 1,336

Post » Fri Mar 28, 2014 11:03 pm

Yes there a freeze when export with node webkit, not when preview.
my layout game is big but without enemies or any thing that will harm the fps.
B
7
S
1
Posts: 65
Reputation: 586

Post » Sat Mar 29, 2014 12:44 pm

@arcgen, No. I don't think there is a lot I can do.

First this seems like a small thing, but I imagine it might be very frustrating on multiplayer games. Just thinking could it be the GC pile up stuff a bit too much and then removing it takes a bit too long. These freezes seems to be longer when it haven't done it in a while.
B
34
S
9
G
3
Posts: 517
Reputation: 5,246

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 17 guests