Two Node-webkit problems still on v.168 [Temp Freeze fix!]

Discussion and feedback on Construct 2

Post » Sun Apr 27, 2014 8:59 pm

For anyone who's suffering from NWK freezes after exporting, try reverting back to 0.8.0, as it is working for us.

LINK:
At this time it is on the front page under downloads and Prebuilt binaries
https://github.com/rogerwang/node-webkit

Remove your game.exe, extract the file to your node-webkit exported project (replace remaining files ), and that's it! You can rename the exe file.


@Ashley @Katala @Arima @shinkan


@Katala Please place this post in your first post, to make it easier to find. :) You can replace link with latest working version!
Last edited by megatronx on Sun Apr 27, 2014 9:44 pm, edited 11 times in total.
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
91
S
30
G
22
Posts: 1,985
Reputation: 20,149

Post » Sun Apr 27, 2014 9:08 pm

Yeah so far this seems the solution to fix it. Still no freezes on both machines. Will keep on testing for awhile longer. Thanks everyone for the help and suggestions.
B
24
S
3
Posts: 42
Reputation: 1,134

Post » Sun Apr 27, 2014 9:26 pm

scaffa wrote:Yeah so far this seems the solution to fix it. Still no freezes on both machines. Will keep on testing for awhile longer. Thanks everyone for the help and suggestions.


Thanks!

I'm still curious to know why preview works, and exported file does not!
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
91
S
30
G
22
Posts: 1,985
Reputation: 20,149

Post » Sun Apr 27, 2014 9:36 pm

Almost cannot believe there is fix to this finally :,)

I would dare to say that v0.8.6 works as well (been running a while now without problems). Probably any v0.8.x will do.
I'm still curious to know why preview works, and exported file does not!

I don't claim to know anything, but on Construct 2\exporters\html5\node-webkit there is

package.json
package-previev.json
package-win.json

so maybe there is still some difference.
B
34
S
9
G
3
Posts: 517
Reputation: 5,246

Post » Sun Apr 27, 2014 9:37 pm

Katala wrote:Almost cannot believe there is fix to this finally :,)

I would dare to say that v0.8.6 works as well (been running a while now without problems). Probably any v0.8.x will do.
I'm still curious to know why preview works, and exported file does not!

I don't claim to know anything, but on Construct 2\exporters\html5\node-webkit there is

package.json
package-previev.json
package-win.json

so maybe there is still some difference.



Dunno. If I'm not mistaken 0.8.1 is the one that is in construct currently ( or is it 0.9.1 ? ). If you have a link to latest nwk version that works for you, please post link here :) Glad to hear it's finally solved. I saw it was some time for you unfortunately.
Last edited by megatronx on Sun Apr 27, 2014 9:43 pm, edited 2 times in total.
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
91
S
30
G
22
Posts: 1,985
Reputation: 20,149

Post » Sun Apr 27, 2014 9:40 pm

At this time it is on the front page under downloads and Prebuilt binaries (v0.8.6 - Apr 18, 2014):
https://github.com/rogerwang/node-webkit
B
34
S
9
G
3
Posts: 517
Reputation: 5,246

Post » Sun Apr 27, 2014 9:43 pm

Katala wrote:At this time it is on the front page under downloads and Prebuilt binaries (v0.8.6 - Apr 18, 2014):
https://github.com/rogerwang/node-webkit


Cheers. I'm trying 0.9.2 now.
Last edited by megatronx on Sun Apr 27, 2014 9:44 pm, edited 1 time in total.
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
91
S
30
G
22
Posts: 1,985
Reputation: 20,149

Post » Sun Apr 27, 2014 9:44 pm

Cool, glad to see you guys are finding workarounds.
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,699

Post » Sun Apr 27, 2014 9:46 pm

I can't remember now, if there was some gpu blacklist problem in nwk 0.9.x or not?! Does anyone remember?
Last edited by megatronx on Sun Apr 27, 2014 9:51 pm, edited 1 time in total.
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
91
S
30
G
22
Posts: 1,985
Reputation: 20,149

Post » Sun Apr 27, 2014 9:50 pm

I can't remember now, if there was some gpu blacklist problem in nwk 0.9.x or not?! Does anyone remembers?

Don't know about that, but node-webkit-v0.9.2-win-ia32 didn't work for me.
B
34
S
9
G
3
Posts: 517
Reputation: 5,246

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests