Two Node-webkit problems still on v.168 [Temp Freeze fix!]

Discussion and feedback on Construct 2

Post » Sun Apr 27, 2014 9:52 pm

Katala wrote:
I can't remember now, if there was some gpu blacklist problem in nwk 0.9.x or not?! Does anyone remembers?

Don't know about that, but node-webkit-v0.9.2-win-ia32 didn't work for me.


Works for me. But that means I wont use it. What gpu do you have?
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
89
S
30
G
22
Posts: 1,985
Reputation: 20,099

Post » Sun Apr 27, 2014 9:57 pm

@megatronx gtx 560 Ti TOP :)

I might try it again since I used a bit different approach to run it.

Edit: Yes it froze almost instantly
Last edited by Katala on Sun Apr 27, 2014 10:02 pm, edited 1 time in total.
B
34
S
9
G
3
Posts: 517
Reputation: 5,226

Post » Sun Apr 27, 2014 10:01 pm

Katala wrote:@megatronx gtx 560 Ti TOP :)

I might try it again since I used a bit different approach to run it.


I've got gt560 non-ti and it runs.
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
89
S
30
G
22
Posts: 1,985
Reputation: 20,099

Post » Sun Apr 27, 2014 10:02 pm

megatronx wrote:[b]For anyone who's suffering from NWK freezes after exporting, try reverting back to 0.8.0, as it is working for us.


That's good...and bad same time hehe NW 0.8.0 is quite old. Newer versions have plenty of nice bugfixes and features added. Like fixes for audio, random crashes or window resize actions. And thats only few I remember.
But well, it's better than freezes anyway. Maybe someone could post this on their bug reports or something to let them now that kind of issue exist between 0.8.0 and newer versions.
ImageImageImageImage
B
157
S
66
G
42
Posts: 2,603
Reputation: 35,343

Post » Sun Apr 27, 2014 10:32 pm

shinkan wrote:
megatronx wrote:[b]For anyone who's suffering from NWK freezes after exporting, try reverting back to 0.8.0, as it is working for us.


That's good...and bad same time hehe NW 0.8.0 is quite old. Newer versions have plenty of nice bugfixes and features added. Like fixes for audio, random crashes or window resize actions. And thats only few I remember.
But well, it's better than freezes anyway. Maybe someone could post this on their bug reports or something to let them now that kind of issue exist between 0.8.0 and newer versions.


Which version is using c2 currently? You can try 0.9.x ? It works for me although will do more tests.
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
89
S
30
G
22
Posts: 1,985
Reputation: 20,099

Post » Sun Apr 27, 2014 10:41 pm

So far 0.8.6 also seems to be working here. Yesterday I tried 0.9.2 but that one did freeze for me. Am I reading it right on the node-webkit page that there are two different versions now that they maintain? 0.8.6 is 2 weeks ago so thats pretty recent.

Is this related to this problem? https:// groups.google.com/forum/#!msg/node-webkit/2OJ1cEMPLlA/09BvpTagSA0J

Yesterday I posted this link here to the node-webkit github, sadly the issue is closed, it also mentions a freezing problem.

https:// github.com/rogerwang/node-webkit/issues/1363
B
24
S
3
Posts: 42
Reputation: 1,134

Post » Sun Apr 27, 2014 10:42 pm

scaffa wrote:So far 0.8.6 also seems to be working here. Yesterday I tried 0.9.2 but that one did freeze for me. Am I reading it right on the node-webkit page that there are two different versions now that they maintain? 0.8.6 is 2 weeks ago so thats pretty recent.

Is this related to this problem? https:// groups.google.com/forum/#!msg/node-webkit/2OJ1cEMPLlA/09BvpTagSA0J

Yesterday I posted this link here to the node-webkit github, sadly the issue is closed, it also mentions a freezing problem.

https:// github.com/rogerwang/node-webkit/issues/1363


So probably they know about those freezes, and they decided to work on 0.8.x. My guess.

Is this related to this problem? https:// groups.google.com/forum/#!msg/node-webkit/2OJ1cEMPLlA/09BvpTagSA0J
No. Post is about upload button that is not working.
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
89
S
30
G
22
Posts: 1,985
Reputation: 20,099

Post » Sun Apr 27, 2014 10:48 pm

@scaffa not sure how this exactly works but there are two branches of NW v0.8.6 - Apr 18, 2014 and v0.9.2 - Feb 20, 2014 and they depends on which Node module you are using - but don't know what's the difference between these Node's

@megatronx since R164 C2 uses NW 0.9.2
ImageImageImageImage
B
157
S
66
G
42
Posts: 2,603
Reputation: 35,343

Post » Sun Apr 27, 2014 10:50 pm

shinkan wrote:@scaffa not sure how this exactly works but there are two branches of NW v0.8.6 - Apr 18, 2014 and v0.9.2 - Feb 20, 2014 and they depends on which Node module you are using - but don't know what's the difference between these Node's

@megatronx since R164 C2 uses NW 0.9.2


Yep... the moment I saw your post, same moment my test started to freeze! XD

Ok, so back to 0.8.6 then.
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
89
S
30
G
22
Posts: 1,985
Reputation: 20,099

Post » Sun Apr 27, 2014 10:55 pm

hehe
So they fu*ked up 0.9.2 then. Nice

Maybe we could ask Ashley to develop his own native exporter? (lol, rotfl, etc. xD)
ImageImageImageImage
B
157
S
66
G
42
Posts: 2,603
Reputation: 35,343

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 12 guests