Unable to activate with @live email address?

Chat about anything not covered in these forums, but keep it civil!

Post » Thu Aug 06, 2009 1:42 am

Okay, so I've went through the whole process of registering here, and I got to the page to where it tells you the activation email is sent. So, I went to my email account, which is an @live.com email address, and it's not in my inbox in my spam folder. I thought, okay, it's probably going to be there, I've just got to wait a few minutes. I waited about 15 minutes, then I decided to resend the email. I then waited around a half hour, and sent one again. Still no luck here, and it's been around 6 hours. The account username is 'Imaku' by the way. I decided to register with my pretty much unused gmail account, and the email got there immediately. I'm just asking here, is there something wrong with @live.com email addresses that doesn't allow you to activate? :|
B
1
G
3
Posts: 1
Reputation: 827

Post » Thu Aug 06, 2009 3:11 am

probably just micro$ocks (yes, socks.) servers lagging up. :mrgreen:
B
25
S
3
G
6
Posts: 1,197
Reputation: 5,620

Post » Thu Aug 06, 2009 2:29 pm

If I remember correctly, I had to use my googlemail address to register here, because after a few attempts at registering with my AOL account, no activation Email ever arrived.

Either this board is setup to avoid using certain ISPs, or our ISPs are blacklisting IP ranges that include the Scirra.com address.

Still, at least you're here now. :)

Sponge.
B
2
S
1
G
3
Posts: 105
Reputation: 1,310

Post » Thu Aug 06, 2009 6:35 pm

Not sure what's going on there - I've manually activated the Imaku account now, though.
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,228

Post » Fri Aug 07, 2009 4:00 pm

Thanks, haha. I guess if you admins need to email me or anything, you'll just have to find another way.
B
2
G
3
Posts: 2
Reputation: 854


Return to Open Topic

Who is online

Users browsing this forum: No registered users and 3 guests