Unable to run layout or debug

Bugs will be moved here once resolved.

Post » Tue Sep 22, 2015 6:59 pm

C2 v212.2 64bit Steam Version
Win10 v 64bitOS
Chrome v 45.0.2454.93

When running a game in localhost:5000 or in Debug the game loads 100% but then goes back to a black screen. Waiting results in a error where my browser(chrome) wants me to either wait for program to respond or kill it. This is happening to both new mostly empty projects as well as older versions that worked well previously.

This is not a new issue with version .1 or .2 but started with the release of v212. But before I could simply restart the game or hit refresh on my browser and the game may work 70% of the time, usually. However starting yesterday and today I am unable to run any of my games in local host. Will try running on another port and will report back.

Checking windows updates I see that my update on 9/22 has failed and will try to fix and or update manually. This my be the problem and will report after fixing windows update.

I am also updating chrome to see if that will resolve my issue.

>>Edit<<

Updated Chrome, Updated Windows no change. Started a new file and seen that I was able to preview and debug and started remaking my game with a focus on optimization. After a few hours I now am unable to preview with it again loading to 100% and then stalling. It seemed that its either once a file gets to a certain size, I guess around 1000KB. Or after a number of hours working on C2. I don't know and will continue to experiment with restarting my pc, steam, and C2 and see where that lands me.

I looked to see if I could export a error report when launching my preview, but was unable to find a way.
"Were all mad here. I'm mad, your mad." "How do you know I'm mad?" Asked Alice. "You must be" Said the Cheshire Cat. "Or you wouldn't have come here"-Lewis Carroll: Adventures In Wonderland
B
7
S
2
Posts: 113
Reputation: 1,245

Post » Wed Sep 23, 2015 12:50 am

>>Update<<

I have found out what the circumstances of this bug are.

When using a .capx created before the v212.1 update it will work fine. However any .capx created after the .1 or .2 update will not launch in any browser I have tried. (Chrome and Firefox)

I don't think there is anything I can do to fix this and seems to be something that needs to be addressed with a patch. Certainly I am not the only one this is happening to.
"Were all mad here. I'm mad, your mad." "How do you know I'm mad?" Asked Alice. "You must be" Said the Cheshire Cat. "Or you wouldn't have come here"-Lewis Carroll: Adventures In Wonderland
B
7
S
2
Posts: 113
Reputation: 1,245

Post » Thu Sep 24, 2015 1:45 am

https://www.dropbox.com/s/mfyboi0fkzyspqk/OfficerMenuDebug.capx?dl=0

Wondering why it's taking so long. And just remembered that without a capx file you wont answer these.
"Were all mad here. I'm mad, your mad." "How do you know I'm mad?" Asked Alice. "You must be" Said the Cheshire Cat. "Or you wouldn't have come here"-Lewis Carroll: Adventures In Wonderland
B
7
S
2
Posts: 113
Reputation: 1,245

Post » Thu Sep 24, 2015 7:08 am

CrazyVulcan wrote:https://www.dropbox.com/s/mfyboi0fkzyspqk/OfficerMenuDebug.capx?dl=0

Wondering why it's taking so long. And just remembered that without a capx file you wont answer these.


From the Must Read First Guidelines:

Why haven't you responded to my bug report yet?
We do look at every report, but developer and release schedules mean we may not get round to it immediately. Please allow a few weeks for it to be investigated. If you are waiting, you can improve the chance it is resolved when a developer does get round to it by carefully reviewing these guidelines and providing as much useful information about the problem as possible. If you are missing anything, you may end up waiting a few weeks for a reply simply asking for the missing information, and then you're waiting again.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
86
Posts: 5,416
Reputation: 59,518

Post » Sun Sep 27, 2015 2:41 am

zenox98 wrote:
CrazyVulcan wrote:https://www.dropbox.com/s/mfyboi0fkzyspqk/OfficerMenuDebug.capx?dl=0

Wondering why it's taking so long. And just remembered that without a capx file you wont answer these.


From the Must Read First Guidelines:

Why haven't you responded to my bug report yet?
We do look at every report, but developer and release schedules mean we may not get round to it immediately. Please allow a few weeks for it to be investigated. If you are waiting, you can improve the chance it is resolved when a developer does get round to it by carefully reviewing these guidelines and providing as much useful information about the problem as possible. If you are missing anything, you may end up waiting a few weeks for a reply simply asking for the missing information, and then you're waiting again.

Thanks @zenox98, just impatient to get back to work. I do believe I found the culprit (Very Likely)

I have 2 computers I use C2 on and was trying to find a way to share my work between them. Using Dropbox, Onedrive and a home network. The files that will not work are the ones I shared on this network and edited between the two computers. I will in the future avoid saving my capx directly to my sharing drive and only share copy's to avoid this. I don't think it is corrupting the file but what ever it did cant be undone. Fortunately I was not far into my redo and the original file backup works just fine.

Take your time in answering/fixing this but I am mostly sure as to what I need to do in the future
"Were all mad here. I'm mad, your mad." "How do you know I'm mad?" Asked Alice. "You must be" Said the Cheshire Cat. "Or you wouldn't have come here"-Lewis Carroll: Adventures In Wonderland
B
7
S
2
Posts: 113
Reputation: 1,245

Post » Mon Oct 12, 2015 3:28 pm

Closing as not a bug. Your example .capx has three separate events that run infinite loops (a single "While" condition), therefore the browser will hang as soon as the game starts.
Scirra Founder
B
398
S
236
G
88
Posts: 24,428
Reputation: 194,600


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests