Unhandled promise rejection: Undefined

All closed bug reports are moved here.

Post » Wed Mar 29, 2017 12:12 am

https://editor.construct.net/
fails to load, I get the error:
"error loading! Unhandled promise rejection: Undefined"

console log:
/offline-root.json?266711 Failed to load resource: the server responded with a status of 521 ()
root-sw.js:289 [Root-SW-Offline] Update check failed: Error: offline-root.json responded with 521
at UpdateCheck.fetchWithBypass.then.response (root-sw.js:211)
UpdateCheck.fetchWithBypass.then.then.catch.err @ root-sw.js:289
register-root-sw.js:17 Registered root service worker on https://editor.construct.net/
http://www.google.com/ads/ga-audiences? ... =361259803 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
/r12/loader/precompiled-en-US.json Failed to load resource: the server responded with a status of 521 ()
/r12/loader/precompiled-en-US.json Failed to load resource: the server responded with a status of 521 ()
/r12/theme/default/import.html Failed to load resource: the server responded with a status of 521 ()
editor.construct.net/:1 Uncaught (in promise) Objectcode: 521response: "<!DOCTYPE html>↵<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US"> <![endif]-->↵<!--[if IE 7]> <html class="no-js ie7 oldie" lang="en-US"> <![endif]-->↵<!--[if IE 8]> <html class="no-js ie8 oldie" lang="en-US"> <![endif]-->↵<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->↵<head>↵↵↵<meta http-equiv="set-cookie" content="cf_use_ob=0; expires=Wed, 29-Mar-17 00:08:36 GMT; path=/">↵↵↵<title>editor.construct.net | 521: Web server is down</title>↵<meta charset="UTF-8" />↵<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />↵<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />↵<meta name="robots" content="noindex, nofollow" />↵<meta name="viewport" content="width=device-width,initial-scale=1,maximum-scale=1" />↵<link rel="stylesheet" id="cf_styles-css" href="/cdn-cgi/styles/cf.errors.css" type="text/css" media="screen,projection" />↵<!--[if lt IE 9]><link rel="stylesheet" id='cf_styles-ie-css' href="/cdn-cgi/styles/cf.errors.ie.css" type="text/css" media="screen,projection" /><![endif]-->↵<style type="text/css">body{margin:0;padding:0}</style>↵<!--[if lte IE 9]><script type="text/javascript" src="/cdn-cgi/scripts/jquery.min.js"></script><![endif]-->↵<!--[if gte IE 10]><!--><script type="text/javascript" src="/cdn-cgi/scripts/zepto.min.js"></script><!--<![endif]-->↵<script type="text/javascript" src="/cdn-cgi/scripts/cf.common.js"></script>↵↵</head>↵<body>↵<div id="cf-wrapper">↵↵ ↵↵ <div id="cf-error-details" class="cf-error-details-wrapper">↵ <div class="cf-wrapper cf-error-overview">↵ <h1>↵ <span class="cf-error-type" data-translate="error">Error</span>↵ <span class="cf-error-code">521</span>↵ <small class="heading-ray-id">Ray ID: 346e97c28d063602 &bull; 2017-03-29 00:08:06 UTC</small>↵ </h1>↵ <h2 class="cf-subheadline" data-translate="error_desc">Web server is down</h2>↵ </div><!-- /.error-overview -->↵↵ <div class="cf-section cf-highlight cf-status-display">↵ <div class="cf-wrapper">↵ <div class="cf-columns cols-3">↵ ↵<div id="cf-browser-status" class="cf-column cf-status-item cf-browser-status ">↵ <div class="cf-icon-error-container">↵ <i class="cf-icon cf-icon-browser"></i>↵ <i class="cf-icon-status cf-icon-ok"></i>↵ </div>↵ <span class="cf-status-desc" data-translate="browser_desc">You</span>↵ <h3 class="cf-status-name" data-translate="browser_label">Browser</h3>↵ <span class="cf-status-label" data-translate="browser_status_label">Working</span>↵</div>↵↵<div id="cf-cloudflare-status" class="cf-column cf-status-item cf-cloudflare-status ">↵ <div class="cf-icon-error-container">↵ <i class="cf-icon cf-icon-cloud"></i>↵ <i class="cf-icon-status cf-icon-ok"></i>↵ </div>↵ <span class="cf-status-desc" data-translate="cloud_desc">London</span>↵ <h3 class="cf-status-name" data-translate="cloud_label">Cloudflare</h3>↵ <span class="cf-status-label" data-translate="cloud_status_label">Working</span>↵</div>↵↵<div id="cf-host-status" class="cf-column cf-status-item cf-host-status cf-error-source">↵ <div class="cf-icon-error-container">↵ <i class="cf-icon cf-icon-server"></i>↵ <i class="cf-icon-status cf-icon-error"></i>↵ </div>↵ <span class="cf-status-desc" data-translate="server_desc">editor.construct.net</span>↵ <h3 class="cf-status-name" data-translate="server_label">Host</h3>↵ <span class="cf-status-label" data-translate="server_status_label">Error</span>↵</div>↵↵ </div>↵ </div>↵ </div><!-- /.status-display -->↵↵ <div class="cf-section cf-wrapper">↵ <div class="cf-columns two">↵ <div class="cf-column">↵ <h2 data-translate="what_happened">What happened?</h2>↵ <p data-translate="not_returning_connection">The web server is not returning a connection. As a result, the web page is not displaying.</p>↵ </div>↵↵ <div class="cf-column">↵ <h2 data-translate="what_can_i_do">What can I do?</h2>↵ <h5 data-translate="if_website_visitor">If you are a visitor of this website:</h5>↵ <p data-translate="try_again_in_a_few">Please try again in a few minutes.</p>↵↵ <h5 data-translate="if_website_owner">If you are the owner of this website:</h5>↵ <p><span data-translate="521_owner_desc">Contact your hosting provider letting them know your web server is not responding.</span> <a data-translate="addtl_troubleshooting" href="https://support.cloudflare.com/hc/en-us/articles/200171916-Error-521">Additional troubleshooting information</a>.</p>↵ </div>↵ </div>↵ </div><!-- /.section -->↵↵ <div class="cf-error-footer cf-wrapper">↵ <p>↵ <span class="cf-footer-item">Cloudflare Ray ID: <strong>346e97c28d063602</strong></span>↵ <span class="cf-footer-separator">&bull;</span>↵ <span class="cf-footer-item"><span data-translate="your_ip">Your IP</span>: 82.26.20.154</span>↵ <span class="cf-footer-separator">&bull;</span>↵ <span class="cf-footer-item"><span data-translate="performance_security_by">Performance &amp; security by</span> <a data-orig-proto="https" data-orig-ref="www.cloudflare.com/5xx-error-landing?utm_source=error_footer" id="brand_link" target="_blank">Cloudflare</a></span>↵ ↵ </p>↵</div><!-- /.error-footer -->↵↵↵ </div><!-- /#cf-error-details -->↵</div><!-- /#cf-wrapper -->↵"status: ""__proto__: Object
main.js:2 [THEME] Error loading from theme/default/import.html: Event
Pe.onerror @ main.js:2
/r12/theme/default/import.html Failed to load resource: the server responded with a status of 521 ()
root-sw.js:1 Service Worker termination by a timeout timer was canceled because DevTools is attached.
B
38
S
14
G
4
Posts: 426
Reputation: 5,686

Post » Wed Mar 29, 2017 5:45 pm

The error includes net::ERR_BLOCKED_BY_CLIENT which sounds like you have a browser addon blocking C3 from loading.

If you disable addons, does it work?
Scirra Founder
B
387
S
230
G
88
Posts: 24,249
Reputation: 192,450

Post » Wed Mar 29, 2017 9:49 pm

you seem to have fixed it now, even with adblock enabled the editor loads.

However sometimes it wont run the demo, and a pop up will say something blocked it - even when adblock is disabled for the site
B
38
S
14
G
4
Posts: 426
Reputation: 5,686

Post » Thu Mar 30, 2017 10:00 am

We didn't change anything! The popup blocker depends on the browser, not addons.
Scirra Founder
B
387
S
230
G
88
Posts: 24,249
Reputation: 192,450

Post » Sat Apr 01, 2017 2:31 pm

hmm, very strange and inconsistent behavior then :)
B
38
S
14
G
4
Posts: 426
Reputation: 5,686


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests