Unnecessary Lag

Discussion and feedback on Construct 2

Post » Thu Jun 14, 2012 10:24 am

This is my first post so I would like to say hi to the community and after a brief look construct seems very promising

I have a problem though, my computer experiences a drop in frame rate when the object count goes over 10. My first attempt at a game is a platformer with multiple solid platforms, they may be overlapping, as they are generated dynamically, is this an issue? The lag is experienced whether the platforms are generated dynamically or placed manually.

I have a laptop with the following specs:
2gig nvidia 335m
2.4 x 4 intel i5
4 gig ddr2 ram
win 7

Which I doubt is the problem as on a little laptop resolution there is almost no modern game I can't play on highest or near highest graphics setting.

I have tried both the latest version of firefox and chrome, which both support hardware accelerated html5 (i think).

I have played a few games on the site's Arcade with no detectable lag issues.

Any suggestions as to why is my computer struggling so much?
B
3
Posts: 2
Reputation: 304

Post » Thu Jun 14, 2012 10:35 am

If you share the *.capx file which you have the problem with, it would help a lot.
B
38
S
13
G
9
Posts: 151
Reputation: 8,427

Post » Thu Jun 14, 2012 11:40 am

I'm drawing 21000+ objects... that could be why

My first time using construct today. My problem is I didn't have a for loop as a sub event, so it was run every tick.

Thanks
B
3
Posts: 2
Reputation: 304


Return to Construct 2 General

Who is online

Users browsing this forum: TheRealDannyyy, Zonacas and 15 guests