unresponsive script issues

Bugs will be moved here once resolved.

Post » Sat Dec 22, 2012 10:40 pm

I'm running Firefox and I isolated the problem to a while that I have in my event sheet. When it's active, it doesn't work. When I disable it, It just runs fine. It's kind of important that this works, so how can I fix it?
B
6
S
1
Posts: 90
Reputation: 840

Post » Sat Dec 22, 2012 11:43 pm

Please see how to report bugs.

It doesn't seem to be a C2 bug, but probably you've made an inifinite while loop.

See the system conditions manual entry:

[quote]While
Repeat the event until one of the other conditions in the event becomes false or a Stop loop action is used. Be careful not to create infinite loops which will cause the game to hang.[/quote]

So here it is, you need another condition along your while that will be false at some point to stop it.
Or use the system action "Stop loop".

This is probably a topic you should have posted in the "How do I" forums, rather than in the "Bugs".
New to Construct ? Where to start



Image Image

Image Image



Please attach a capx to any help request or bug report !
Moderator
B
262
S
93
G
55
Posts: 7,147
Reputation: 67,063

Post » Sun Dec 23, 2012 1:10 pm

Closing, please see how to report bugs. If you provide enough information for us to investigate the issue, we will reopen the bug.
Scirra Founder
B
373
S
218
G
84
Posts: 23,440
Reputation: 186,070


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest