uploading game on newgrounds

Discussion and feedback on Construct 2

Post » Fri Jun 26, 2015 9:01 pm

delgado, this shouldn't be a problem. The problem comes with characters or words with punctuation which english does not use. Also "´" "`". Double check the files names of all the objects in the project. It happened to me once, neglecting a single "ç" resulted with me unable to load my game on Newgrounds and almost throwing my pc on the wall. :)
B
6
Posts: 9
Reputation: 270

Post » Fri Jun 26, 2015 9:25 pm

@Macebo i have "(" and ")" in my sound files this might cause problem too?
B
114
S
29
G
48
Posts: 1,883
Reputation: 36,605

Post » Sat Jun 27, 2015 12:04 am

I believe this "(" is possible to use, but unconventional, which may result problems depending on the language of the program is using to read your content. My advice is: stick to the conventional: we normally use "_" to link words (which is similar to a space) or a simple dot "." Or, in the case of Construct, i usually do something like this: "family_object_instance(or index, using a number).
* " [ ] : ; | = these are the other ones i can remember by head, and can't recommend using for naming files.
Alright, so to the actual problem: i saw you're from Poland. There is a lot of characters with accents in the polish alphabet - even on consonants. Am i right? If so, if i were you i would try and get rid of them.
Good luck!
Last edited by Macebo on Sat Jun 27, 2015 1:25 am, edited 1 time in total.
B
6
Posts: 9
Reputation: 270

Post » Sat Jun 27, 2015 12:33 am

Macebo wrote:Since OP seems like non-english speaker, i can assure that some of his files contain characters like "ç" "^" "~" etc used in other languages (like portuguese).
Make sure all of your files do not contain these foreign characters. It makes trouble when the browser begins to read the files, and that's why the loading bar becomes red.


You were right, Macebo :o
I had 3 "~". when you told me that I changed 2 "~" but left one, well hidden. so the problem remained.
many thanks to you.

Also, this tip should be fixed in the beginners guide. Seriously.
B
11
S
3
G
3
Posts: 5
Reputation: 3,179

Post » Sat Jun 27, 2015 8:29 am

@Rockssc you find this on description, sprites, sounds?
B
114
S
29
G
48
Posts: 1,883
Reputation: 36,605

Post » Sat Jun 27, 2015 11:29 am

@delgado I found two in a text and one as the name of a sprite. I do not know if it can happen to sounds.
if you are also with this problem so check all the names of your files ,one by one, carefully.
B
11
S
3
G
3
Posts: 5
Reputation: 3,179

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests