Uploading to Chrome Store - Black Screen

Discussion and feedback on Construct 2

Post » Fri Aug 24, 2012 1:54 am

I just ran into this same issue. Just a black screen when I try to test/play the game.

B
94
S
29
G
11
Posts: 1,545
Reputation: 20,993

Post » Fri Aug 24, 2012 9:42 am

The Chrome Web Store has introduced much tighter security restrictions, which breaks exported C2 games. I've adapted the export to fit the new restrictions, and I've successfully submitted a working game to the Chrome Web Store. So hopefully this is all fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri Aug 24, 2012 2:37 pm

Thanks Ashley.
B
94
S
29
G
11
Posts: 1,545
Reputation: 20,993

Post » Sat Sep 01, 2012 12:53 am

I'm having the same problem with r101. I upload, test and just get a black screen still. Anyone having success uploading to Chrome Store since r95?
B
94
S
29
G
11
Posts: 1,545
Reputation: 20,993

Post » Sun Sep 02, 2012 8:45 pm

Can anyone confirm it's working or not? I'm hoping it just not me :).
B
94
S
29
G
11
Posts: 1,545
Reputation: 20,993

Post » Mon Sep 03, 2012 2:45 am

I manage to upload my first game on chrome via r99.

https://chrome.google.com/webstore/detail/elallonifhfogmgecnnegkkclagnndla?hl=en-GB


I will try to repack with r101 and upload again later today to test it out.
B
6
S
1
Posts: 62
Reputation: 1,697

Post » Mon Sep 03, 2012 4:45 am

Is it being hosted through chrome, or are you hosting it?

B
94
S
29
G
11
Posts: 1,545
Reputation: 20,993

Post » Mon Sep 03, 2012 1:17 pm

Hosted on chrome.
B
6
S
1
Posts: 62
Reputation: 1,697

Post » Tue Sep 04, 2012 8:58 am

I just tried it with R101, and I got the same problem just a black screen but my icon_16 is showing up well on the page tab.Wink2012-09-04 09:04:43
B
50
S
11
G
8
Posts: 479
Reputation: 9,911

Post » Tue Sep 04, 2012 11:34 am

In testing for r101 I successfully published an app to the Chrome Web Store and it worked fine. I have no idea why it's not working. Can you share your .capx files that aren't working so I can investigate? Also if you bring up the Chrome Developer Tools (I think they still work for CWS apps), are there any errors etc?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 15 guests