Usermedia Text to Speech long text 'is speaking' never ends

Bugs will be moved here once resolved.

Post » Thu May 22, 2014 5:48 pm

Problem Description
I am using the UserMedia to do text-to-speech to read out the game as part of an accessibility jam. It works fine for short pieces of text but when I put in a longer text to be spoken it speaks it, but never seems to release. I use the 'Is Speaking' property to do other things but that flag never gets turned off during long text. I added a red 'speaking' sprite to indicate when 'Is Speaking' is on or off. It never turns off after the first text is read.

Attach a Capx
Uploaded!

Description of Capx
Has a text object with a large amount of text and 4 text 'buttons' below. When you click on them they should use the text to speech and read out their text contents.

Steps to Reproduce Bug
  • click one of the buttons, it reads and a red square is visible while talking.
  • click the large text box, it reads but the red square never goes away after it's finished speaking.

Observed Result
Notice the red sprite in the top left stays on after reading the large amount of text.

Expected Result
The red sprite in the top left should disappear when the text has been read.

Affected Browsers
  • Chrome: (YES)
  • FireFox: (NO)
  • Internet Explorer: (NO)

Operating System and Service Pack
Windows 8.1 U1

Construct 2 Version ID
R168 64bit Steam
You do not have the required permissions to view the files attached to this post.
B
31
S
7
G
1
Posts: 80
Reputation: 2,550

Post » Mon Jun 02, 2014 2:42 pm

I've looked at this and can reproduce it in Chrome, but our code is correct - Chrome itself is indicating that the voice is still speaking when it is not. Closing as won't fix, I'd recommend reporting this to Google.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests