V-Sync not Working

For questions about using Classic.

Post » Tue Mar 13, 2012 9:45 am

Hey Guys,

Is there a way to enable vsync in fullscreen-mode? If i run my game windowed i get rock solid and smooth 60 fps which are vsynced. In fullscreen i get 650+ fps that are stuttering very much.

Why vsync does not work in fullscreen mode? In my graphics drivers all settings are on default values.
B
7
S
2
G
2
Posts: 45
Reputation: 1,465

Post » Wed Mar 14, 2012 10:20 am

Now i have testet all my cap`s on 4 different computer. all with the same result. vsync does not work fullscreen in construct r2.

is there a way to fix this? i have to release my game in near future and i really need fullscreen support.
B
7
S
2
G
2
Posts: 45
Reputation: 1,465

Post » Wed Mar 14, 2012 1:25 pm

Is vsync turned on or off on your gfx card settings?.I don't have any problems running vsync in fullscreen mode.What is resolution when you switch over to vsync?.And what operating systems are you testing the game on.If you can make an example cap file then we might be able to help.
B
22
S
3
G
6
Posts: 1,356
Reputation: 7,141

Post » Wed Mar 14, 2012 1:33 pm

I also have no problems running vsync in fullscreen mode.
Spriter Dev
B
87
S
21
G
12
Posts: 3,240
Reputation: 16,461

Post » Wed Mar 14, 2012 4:57 pm

It seems unlikely since it's across multiple machines, but try updating your graphics card drivers, that might be the problem. At one point my graphics card refused to use vsync at all and updating my graphics card drivers fixed it.Arima2012-03-14 17:01:15
Moderator
B
87
S
32
G
33
Posts: 3,005
Reputation: 27,397

Post » Wed Mar 14, 2012 5:30 pm

Thanks for your quick replys.

All computers i have testet it on have Windows 7 64 Bit installed and have newer Nvidia Cards like Gtx560 and Gtx580.

All Systems are up to Date, DX is up to Date, Drivers too.
All Settings in the Nvidia Panel are set to default Values.

Vsync is enabled in the Application settings in my Project and works like it should in Window-Mode. I am trying to run it at 1280x720 px Fullscreen but the Problem is independent from the Resolution.

To bad i can not post a cap because its from a commercial project we are working on. I have crated a blank cap and startet it fullscreen and the Problem does not exist there. So what can cause Vsync not to work like it should? Its like switching on and of rapidly. Framerates changes from 60FPS to 600PFS ten times a second.

UnixRoot2012-03-14 17:33:03
B
7
S
2
G
2
Posts: 45
Reputation: 1,465

Post » Wed Mar 14, 2012 5:48 pm

My best guess would be to save a copy, then delete events and objects from it in large chunks until the problem stops. If you end up with a blank .cap and the problem still happens, then I have no idea.
Moderator
B
87
S
32
G
33
Posts: 3,005
Reputation: 27,397

Post » Wed Mar 14, 2012 8:37 pm

No problem for me with winxp. Perhaps it's a win7 specific issue?
B
79
S
24
G
52
Posts: 4,725
Reputation: 39,713

Post » Wed Mar 14, 2012 9:16 pm

Possible, but it only happens since the r2 Update.
B
7
S
2
G
2
Posts: 45
Reputation: 1,465

Post » Wed Mar 14, 2012 9:18 pm

Winxp home and pro editions 32 bit = Works fine
Win 7 Basic and Premiun 64 bit = Works fine

I tested it with a nvidia geforce 8800 gs card , A mobile ati radeon 5450
and an Intel hd 2000 card and each one does not come up with any probs ,i have tried to create non power off 2 tilesets and huge textures but i still don't get the framerate problems.

Try to re install Classic Construct and see what happens.
B
22
S
3
G
6
Posts: 1,356
Reputation: 7,141

Next

Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 3 guests