Variable Jump is not behaving quite right Plz Help

Get help using Construct 2

Post » Tue Oct 09, 2012 1:52 pm

Hi,

I have put in a variable jump in my game using a Variable set to the character called JumpBoost. When the button is held down the character will carry on jumping until this variable gets to a certain number using the platforms vector command. This works perfectly on the PC and on powerful mobile devices such as the iPhone 4s and Galaxy Android phones.

However, when testing this method on an iPhone 4 and, even worse, the 3gs, the character jumps less high suggesting this is CPU bound. So I have set the increase of the JumpBoost Variable to "-300 * dt" rather than just "-5" expecting this to solve the problem. But it does not.

It's obviously a problem as the 3gs and iPhone 4 version can't make the same jumps as the 4s/5. Can someone help out on this issue.

Thank you,
Shelby
B
20
S
3
G
4
Posts: 77
Reputation: 3,346

Post » Wed Oct 10, 2012 9:42 pm

Argh, I'm really trying hard to find a solution to this problem. If it isn't solvable then it basically makes a decent platformer not possible at the moment with construct 2 :(.

Please could someone help
B
20
S
3
G
4
Posts: 77
Reputation: 3,346

Post » Thu Oct 11, 2012 1:50 am

Probably , The Framerate ... try to use the physics behavior !
B
35
S
16
G
16
Posts: 2,222
Reputation: 16,589

Post » Thu Oct 11, 2012 12:27 pm

Cheers for the reply, do you know how you would set up a jump with the physics behaviour?
B
20
S
3
G
4
Posts: 77
Reputation: 3,346


Return to How do I....?

Who is online

Users browsing this forum: Callan S, gamecorpstudio, Kagubro and 11 guests