Variable & Wait bug

Bugs will be moved here once resolved.

Post » Tue May 27, 2014 1:20 am

Problem Description
____ The Variable & Wait event's don't work on time exactly ____

Attach a Capx
____ Upload a Capx to this post ____

Description of Capx
____ One sprite - one global variable - two events ____

Steps to Reproduce Bug
  • watch the screen for one min and you will see the problem
  • Step 2
  • Step 3 etc.

Observed Result
____ The sprite not following the wait event some times the event ordering the sprite to be transparent but you can see the sprite flashing ____

Expected Result
____ It's suppose when variable 0 work the opacity become 0____

Affected Browsers
  • Chrome: (YES, you can see the problem always)
  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
____ win 7 - Service Pack 1 ____

Construct 2 Version ID
____ r 170 beta ____

=====
This is very old bug, I've seen it before 4 months.
Not only with opacity it effect collision and visible.
You do not have the required permissions to view the files attached to this post.
B
60
S
10
G
10
Posts: 1,013
Reputation: 9,165

Post » Mon Jun 02, 2014 3:28 pm

Closing as not a bug, you misunderstand how 'Wait' works. It doesn't pause all the events. 'z = 0' is true all the time, so every tick (60 times a second) you're queuing up a new 'wait 3 seconds then set z to 1' command. The next event then starts conflicting with that since it is every tick (60 times a second) also queuing up a new 'wait 5 seconds then set z to 0' command. Solution: add 'trigger once' to both events.
Scirra Founder
B
403
S
238
G
89
Posts: 24,654
Reputation: 196,155

Post » Fri Apr 14, 2017 10:44 am

Ashley wrote: Solution: add 'trigger once' to both events.

Dude, you saved my brain! :lol: Thanks a lot!
B
5
Posts: 1
Reputation: 227


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 7 guests