Vehicle Behaviour + More Questions

For questions about using Classic.

Post » Sun Nov 01, 2009 10:14 am

Hey, I'm just having some problems with the vehicle behaviour in the latest build, namely that:

1. The reverse doesn't stop reversing, there is no friction, so you just keep going until you accelerate again.

2. I can't reassign controls. I'm trying to get a WASD control scheme but it seems to break the behaviour.

Thanks in advance.
B
55
S
12
G
8
Posts: 339
Reputation: 9,314

Post » Mon Nov 02, 2009 7:59 am

Okay and just another question. I have a bunch of objects following my main character, each at a fixes position in relation to it. Sort of like a line of ants. I've got it so that they follow it, but it acts like one rigid body. How can I get it so that the objects follow with a more snakelike movement?

Hmmm... While the 3:0 ratio isn't promising, here's another question: I want to procedurally generate a map. It should be simple, as there are only two types of objects: Ammo and Enemy. But basically I figure I need at the start of the layout for Construct to randomly place a number of these objects, but I have no idea how. Any ideas? [Ok, figured it out.]
B
55
S
12
G
8
Posts: 339
Reputation: 9,314

Post » Thu Nov 05, 2009 5:22 am

I hate to bump a topic, but this is for the GameJolt competition that ends this weekend. Anyone?
B
55
S
12
G
8
Posts: 339
Reputation: 9,314

Post » Thu Nov 05, 2009 9:10 am

For the car behavior:

1. You could manually adjust the speed. I think speed goes negative when you are reversing, so have some event to increase the speed (towards zero) when reversing.

2. All behavior's controls are specified in Application Properties, under Controls header. You should be able to change up/down/left/right to WASD there.
Scirra Founder
B
359
S
214
G
72
Posts: 22,951
Reputation: 178,578


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 1 guest