Very lagging in Debian Linux

Get help using Construct 2

Post » Thu Feb 21, 2013 3:05 pm

Game seems to be very lagging in Linux after exporting from a windows...Please help.
B
2
Posts: 4
Reputation: 358

Post » Thu Feb 21, 2013 5:56 pm

Sounds like a driver issue.

Add a textbox and set it's content to "renderer" (without the qutation marks). If implemented correctly, it will output the default renderer currently employed by your browser (either WebGL or, worst case scenario, Canvas).

It would also help if you could add your computer's specs to the original post and either upload or describe the game you're trying to run (e. g. does it use physics? Total/approximate amount of objects on screen? Custom behaviour, pathfinding, etc?)
B
6
S
2
Posts: 206
Reputation: 1,685

Post » Fri Feb 22, 2013 12:25 am

Yes, it's driver issue, sometimes if video driver is not installed, lags everything
B
96
S
25
G
20
Posts: 3,055
Reputation: 22,644

Post » Fri Feb 22, 2013 1:01 am

[QUOTE=Joannesalfa] Yes, it's driver issue, sometimes if video driver is not installed, lags everything[/QUOTE]

Either that or his GPU/driver is blacklisted.
B
6
S
2
Posts: 206
Reputation: 1,685

Post » Fri Feb 22, 2013 1:05 pm

Install Google Chrome, and visit the URL chrome://gpu. It should tell you how well the rendering is supported (e.g. hardware-accelerated WebGL, software-accelerated canvas, etc). It's the same engine as node-webkit so support should match what your game gets.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 18 guests