Very strange drawing bug

Bugs will be moved here once resolved.

Post » Fri Apr 26, 2013 5:12 pm

Link to .capx file (required!):
https://dl.dropboxusercontent.com/u/41931267/VeryOddBug.capx

Steps to reproduce:
1. Run capx
2. Move around with arrow keys

Observed result:
Here's an image of the effect on my PC.



Basically, it seems that every tick, the main player object leaves an 'imprint' of itself on the background.

I found this issue after I accidentally deleted the background sprite in a larger project. So, I backed up the project and began to cut out everything that wasn't a part of the issue. For some reason, there is one object (I called it 'WhyDoesThisBugTheGame) that causes this issue - if I delete it, the issue remains (although the background is still strangely black. Shouldn't it be grey?)

If the issue doesn't occur for anyone else then I'll assume it's a graphics driver issue, however I'm fairly sure I'm updated.

This isn't a webgl issue either, as it also happens with webgl off.

Browsers affected:
Chrome: yes
Firefox: yes
Internet Explorer: yes

Operating system & service pack:
Windows 7 64bit

Construct 2 version:
r127 (but it definitely occurred before r127)
    
    
B
90
S
30
G
24
Posts: 3,189
Reputation: 32,400

Post » Fri Apr 26, 2013 6:34 pm

You've got Transparency set to YES on the Layer! Someone actually wrote a game a while back that took advantage of this.
ImageImageImage
B
67
S
19
G
121
Posts: 3,200
Reputation: 72,887

Post » Fri Apr 26, 2013 6:35 pm

Closing as not a bug: you have a transparent layer and 'clear background' set to 'no', so you've told Construct 2 to never clear between frames.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,518

Post » Fri Apr 26, 2013 8:46 pm

@Ashley Ah - I was confused as the removal of that other object actually fixed the problem. Sorry.
B
90
S
30
G
24
Posts: 3,189
Reputation: 32,400


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest