Video playback in IOS triggers distortion of audio playback

Report Construct 2 bugs here.

Post » Mon Jan 23, 2017 5:27 pm

Problem Description
If a video is played in IOS Safari, then an audio is played, the audio is distorted. May relate to the well known sample rate bug from last year. Tested with Safari on an iphone 5s with ios 10 and an ipad mini with ios 9.

Attach a Capx
https://www.brightware.co.uk/construct2 ... rtion.capx

Description of Capx
The capx has a button to play an audio file (short sound effect) and a button to play a short video (mp4). Press the "Play Sound" button and the sound will play fine. Press the "Play Video" button and the video will play. Wait for the video to finish (about 4 seconds). Press the "Play Sound" button again and the audio will be distorted. If you reload the browser, the bug goes away. If you close the tab, start a new one, the bug returns.

Steps to Reproduce Bug
  • Press the "Play Sound" button. Wait for the sound to finish. It should sound fine. Press it repeatedly.
  • Press the "Play Video" button and the video will play. Wait for the video to finish (about 4 seconds).
  • Press the "Play Sound" button again and the audio will be distorted.
  • If you reload the browser, the bug goes away. If you close the tab, start a new one, the bug returns.

Observed Result
Audio becomes distorted after video playback.

Expected Result
Audio should not be distorted.

Affected Browsers
  • IOS 10 Safari iphone 5s
  • IOS 9 Safari ipad mini 1

Operating System and Service Pack
Win 10 Pro

Construct 2 Version ID
239 (64 bit)
B
7
S
2
Posts: 22
Reputation: 529

Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests