NW.js issue

Discussion and feedback on Construct 2

Post » Wed Jun 08, 2016 10:58 pm

Ok, so I wanted to see if anyone ran into this issue. I made a application that is a pretty simple reference tool that links to various sites. If I export it was a HTML, the program will run fine, however I wanted to make this a NW.js file.

The issue with this is, if I export it with a "Window Frame" the program will crash pretty consistently once a user clicks any of the links. Sometimes you can click a single link successfully, but never more than 2. After opening a link or 2 the entire program closes out. No error messages or indication as to why as far as I can see.

I tried playing around with the settings (resizable, kiosk, minified on and off, compression from default to none) with the same results. It wasn't until I unchecked the "Window frame" that the program stopped crashing. The only issue that I have with this is, it's difficult for users to expand and navigate with this option off.

I ran this on 2 Windows 8.1 computers, both with 8gb of memory, a gig of video memory (Intel HD), fully updated OS, drivers, Java.

Anyone run into a similar issue? It's pretty disappointing to have this happen coming back to this program. At this point I may just scrap this program and use a different editor. Thanks
B
3
G
1
Posts: 5
Reputation: 585

Post » Thu Jun 09, 2016 5:46 am

Are you executing nw.js api script to open a default browser window, or are you using the Browser object to do it? The Browser object only works on browsers, not nw.js... See here for the api.
A big fan of JavaScript.
B
76
S
20
G
73
Posts: 2,241
Reputation: 45,956

Post » Fri Jun 10, 2016 12:13 am

Example: duck (on clicked) Browser (open new window) go to http://www.somewebsite.com

Preview browser (default, Chrome, Firefox)

Export to: NW.js
B
3
G
1
Posts: 5
Reputation: 585

Post » Sat Jun 11, 2016 2:35 am

Preview browser has to be NW.js also.

You need to download and install NW.js from HERE

~Sol
Tired of crappy file hosts that are crappy? Get DROPBOX - https://db.tt/uwjysXJF
Moderator
B
84
S
34
G
40
Posts: 3,032
Reputation: 30,499

Post » Wed Jun 15, 2016 4:25 am

I will give that a try, thank you
B
3
G
1
Posts: 5
Reputation: 585

Post » Thu Jun 16, 2016 4:00 pm

Well I tried it and having the exact same issue(s) across multiple systems. Thanks, but I'm going to just move this project to something else.
B
3
G
1
Posts: 5
Reputation: 585


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 4 guests