R240 64-bits Minifying issue

Bugs will be moved here once resolved.

Post » Mon Dec 05, 2016 5:11 pm

I'm here because I just found the issue as well. Seeing the same error window.

I'm not sure if Pinellos' is the same problem, as in my tests (mostly exporting to arcade), if it won't work, it won't no matter the folders, or graphics.
I also tried Signupdemos's suggestion of the browser plugin, and adding the object to a working capx causes the error, and removing it lets it work again. By TELLES0808's comment, it's probably more than one object triggering it.
however, I've tried adding all the other objects, and it's the only one that triggered the error in a working capx.

Removing the browser object from Space Blaster lets it minify.
B
240
S
62
G
33
Posts: 903
Reputation: 40,589

Post » Fri Dec 16, 2016 6:26 pm

same issue here with r240 in both 32 and 64 version. Tried to trace. When Construct2 calls the minifier this will end up like that in my case:

C:\Users\M>java -jar "C:\Program Files\Construct 2\exporters\html5\tools\closure\compiler.jar" --js "D:\Projekte\Construct 2\2016\Notenmeister\HTML\c2runtime_tmp.js" --js_output_file "D:\Projekte\Construct 2\2016\Notenmeister\HTML\c2runtime_min.js" --language_in ECMASCRIPT5_STRICT --compilation_level ADVANCED_OPTIMIZATIONS --externs "C:\Program Files\Construct 2\exporters\html5\jquery-externs.js" --externs "C:\Program Files\Construct 2\exporters\html5\c2-externs.js"
D:\Projekte\Construct 2\2016\Notenmeister\HTML\c2runtime_tmp.js:19285: ERROR - this language feature is only supported in es6 mode: let declarations. Use --language_in=ECMASCRIPT6 or ECMASCRIPT6_STRICT to enable ES6 features.
let browserInstance = null;
^

1 error(s), 0 warning(s)

May be there are new features not supported by the minifier?
B
5
S
1
Posts: 2
Reputation: 279

Post » Sat Dec 17, 2016 3:34 pm

On the browser plugin runtime.js line 54, I replaced
Code: Select all
 let browserInstance = null;

with
Code: Select all
 var browserInstance = null;

then I could use the minifier again. As a temporary solution it should work.
B
5
S
1
G
1
Posts: 24
Reputation: 538

Post » Sun Dec 18, 2016 7:15 pm

Nemega wrote:On the browser plugin runtime.js line 54, I replaced
Code: Select all
 let browserInstance = null;

with
Code: Select all
 var browserInstance = null;

then I could use the minifier again. As a temporary solution it should work.


Thanks @Nemega

This worked for me.
B
74
S
13
G
4
Posts: 1,006
Reputation: 8,060

Post » Mon Dec 19, 2016 5:25 pm

Thanks @Nemega for working out the plugin causing issues.

Now the minifier is working here too.
Hope there will be a fix with the next Release of Construct 2.
B
5
S
1
Posts: 2
Reputation: 279

Post » Tue Dec 20, 2016 6:48 pm

Ah, looks like a JS error that was breaking the minifier after all. It's the same issue that broke the Browser plugin on iOS 9. Should be fixed in the next build now.
Scirra Founder
B
399
S
236
G
89
Posts: 24,528
Reputation: 195,388

Post » Thu Apr 20, 2017 2:01 pm

@Ashley construct 2 r244 or r243 64 bits don't minify for me
B
14
S
3
Posts: 21
Reputation: 832

Post » Thu Apr 20, 2017 4:20 pm

@tamixx - this is a closed report, please file a new report following all the guidelines
Scirra Founder
B
399
S
236
G
89
Posts: 24,528
Reputation: 195,388

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests