Family and Pathfinding - Obstacle solid and custom

Bugs will be moved here once resolved.

Post » Sun Feb 19, 2017 2:50 pm

Problem Description
When I put two different objects in a same family with pathfinding behavior on the familie it seem's impossible to use one with the paramters obstacle as custom and the other as solid.

Is-it a bug ou wanted by design ?


Steps to Reproduce Bug

Observed Result
The two sprites use the same obstacle parameters (and the parameters of the first one created)

Expected Result
I expected that only the sprite with custom obstacle could go trough the wall.

Affected Browsers

  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
windows 10

Construct 2 Version ID
Contruct 2 r239
B
13
S
2
Posts: 14
Reputation: 650

Post » Sun Feb 19, 2017 8:19 pm

Observed Result
The two sprites use the same obstacle parameters

That's because they're both using a family pathfinding behaviour.

It's not impossible to do, just give them their own separately named pathfinding behaviours if they are going to be different, don't use the shared family one.
B
43
S
13
G
59
Posts: 1,779
Reputation: 35,731

Post » Mon Feb 20, 2017 3:51 pm

I'm afraid this is currently by design: the family uses one behavior, and one behavior only uses one shared obstacle map.
Scirra Founder
B
373
S
218
G
84
Posts: 23,450
Reputation: 186,140

Post » Mon Feb 20, 2017 9:43 pm

@plinkie @Ashley Thank you for your answers. I just tried using a second behaviour but it doesn't seem to work differently. I'll try harder this week-end (perhaps I'm a bit too tired this evening).
B
13
S
2
Posts: 14
Reputation: 650


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests