[Photon] SecureWebSocket on Self-hosted Amazon EC2

Post » Wed Aug 09, 2017 8:24 am

Message: giangnd can only post plain text URLS until they have 500 rep. 2 URLS modified. Why?
Hi,
I'm having trouble when I try to connect my self-hosted server (Amazon EC2), using Secure Websocket connection, I followed this tutorial to allow wss: https://doc.photonengine.com/en-us/onpr ... -ssl-setup.

I'm guessing that the problem is related with my certificate but I'm not entirely sure. I tried trusted Certificate Authority one (free SLL Certificate from https://www.comodo.com).

Here is the error (i'm using Public IP address):
Image

Photon Config in Construct 2:
Image

Here is app's websocket listener in PhotonServer.config:
Code: Select all
<WebSocketListener
   IPAddress="0.0.0.0"
   Port="9090"
   DisableNagle="true"
   InactivityTimeout="10000"
   OverrideApplication="Master"
   Secure = "true"
   StoreName = "MY"
   CertificateName = "mydomain.com"
   UseMachineStore = "true">     
</WebSocketListener>

<WebSocketListener
   IPAddress="0.0.0.0"
   Port="9091"
   DisableNagle="true"
   InactivityTimeout="10000"
   OverrideApplication="Game"
   Secure = "true"
   StoreName = "MY"
   CertificateName = "mydomain.com"
   UseMachineStore = "true">     
</WebSocketListener>


Here is my Certificate Authority on Windows Server 2012 R2:
Image

"Local computer" certificate store
Image

Thank you
B
8
S
4
G
1
Posts: 1
Reputation: 1,202

Post » Sat Jan 06, 2018 11:05 pm

Hey

Did you ever fix this? I'm running into a similar issue.
Black Bobby The Hole RPG game Greenlit with 303 votes.
B
44
S
10
G
1
Posts: 193
Reputation: 3,546

Post » Sun Jan 14, 2018 5:22 pm

Curious if Amazon is shipping their windows servers with crypto protocols disabled...
Download IIScrypto from the web and use it to check if your cert's cypher or protocols are disabled? If so, use that tool to enable and try again?
B
4
S
1
Posts: 13
Reputation: 819


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests