Android Crosswalk Plays Music Always At Max Volume

Discussion and feedback on Construct 2

Post » Mon Oct 20, 2014 6:29 pm

Hi @ all,

I had described this problem one week ago in the beginners questions sub forum but the topic didn’t get any attention there. So I try it again here.
In my game you can set the volume for sound and for music. Everything works with every browser and also in the emulator of the Intel XDK. Once exported and installed on android the music always plays at normal volume (+-0db) even if I hardcode -100DB it has no impact.

Did anyone else have seen this behaviour?

@Ashley, as this seems to be a crosswalk bug would you kindly address this issue to the developers? I can also do it myself if you wish, but I don’t have the programming knowledge to tell them where exactly this happens in the script. I would highly appreciate if you would take a look at it.
One Possible Solution would be to import the music as “Sound” but then the decoding at start takes a huge amount of time, as android seems to have some problems with this.

With kind regards
joschi
B
19
S
7
G
1
Posts: 222
Reputation: 2,551

Post » Thu Oct 23, 2014 4:11 am

@IntelRobert can you give me any hint on this? should i report this anywhere?

Does no one else has volume controll in his games or i am the only one with this problem?

regards
B
19
S
7
G
1
Posts: 222
Reputation: 2,551

Post » Thu Oct 23, 2014 4:22 am

I'm personally not having this issue and haven't seen anyone else with it. can you post a screenshot of your sound events and/or have you made a minimum build to test if it's not just something else. also have you tested on more then one device it might be your device
B
42
S
17
G
2
Posts: 850
Reputation: 6,209

Post » Thu Oct 23, 2014 12:47 pm

It sounds like another instance of a chromium//android issue
https://code.google.com/p/chromium/issu ... ?id=240415

You can check by using C2 preview over wifi with chrome running on your android device. It will work in chrome on desktop, but not chrome on android.

Crosswalk issue: https://crosswalk-project.org/jira/browse/XWALK-1126

If you find that it works on chrome/android, but not crosswalk, then PM me with an example to test.

j0schi wrote:@IntelRobert can you give me any hint on this? should i report this anywhere?

Does no one else has volume controll in his games or i am the only one with this problem?

regards
Intel Corporation
B
15
S
3
Posts: 193
Reputation: 1,552

Post » Sat Oct 25, 2014 12:43 am

@IntelRobert thank you for adressing this.
BUT the slider for the music works in chrome over wlan preview. the music takes a long time to start and sounds are not played at all. so this could be related, but it could also be another problem. in the menu sounds are fine (played on tab of a button) in the game itself the music is fine (after a long loading time) and gets played at the right volume, but not the sounds...

if you like you can test everything youself here: http://bytecrunch.org/games/ocp1/

hopefully this issue gets sorted out soon... i cant release any game with those kind of bugs (this and the jankyness which is discussed in other threads)
my programming knowledge is very limeted, but let me know if i can help in any way... i can also buy you a coffee or something :)

kind regards
Joschi...
B
19
S
7
G
1
Posts: 222
Reputation: 2,551

Post » Sat Oct 25, 2014 5:24 pm

@j0schi

I see the same behavior in chrome and crosswalk 8. If you are seeing a difference, can you explain more? Here is what I did:

Start chrome on my nexus 4. Point it to: http://bytecrunch.org/games/ocp1/
Hard volume button controls music and effects. The sliders in your option page can control the effects, but not the music.

Then using the crosswalk test app: https://drive.google.com/folderview?id= ... sp=sharing
I do the same thing and see the same behavior. Hard volume buttons work, Sliders control effects, but not music.
Intel Corporation
B
15
S
3
Posts: 193
Reputation: 1,552

Post » Sat Oct 25, 2014 11:47 pm

@IntelRobert

Here is what i did:

1) start chrome on my samsung galaxy s2 Point it to http://bytecrunch.org/games/ocp1/
sounds and music work in menu, when i start the game only music works, however if i change the colume of the music in the options it takes effect in the game

2) start chrome on my desktop point it to http://bytecrunch.org/games/ocp1/ everything works. same with any other browser

3) start the app in the intel xdk emulator everything works

4) exported app with crosswalk wrapper -> install it on my galaxy s2 everything works exept the volume controll for the music

it seems that the bug you have with crome for android i only have with crosswalk

Chrome Version on my S2: 38.0.2125.102 2125102
Android: 4.1.2 GT-I9100
Blink: 537.36
Javascript: V83.28.71.15

regards
joschi
B
19
S
7
G
1
Posts: 222
Reputation: 2,551

Post » Sun Oct 26, 2014 12:00 am

Exactly same thing here on S3, volume control for the music do not work at all in crosswalk.
ImageImageImageImage
B
158
S
67
G
43
Posts: 2,603
Reputation: 36,003

Post » Sun Oct 26, 2014 6:57 am

@IntelRobert i tested this issue sound toggle mute is not working on latest top 10 android devices.. cant release app due to this issue..
B
16
S
4
Posts: 53
Reputation: 1,226

Post » Sun Oct 26, 2014 4:32 pm

@cooltaby thats only one issue for me, the othert is this here: viewtopic.php?f=146&t=117554 do you have a demo of your game online? i would be interested if those issues are there too. currently i reconsidder cocoonjs (even if i dont want to use it beacause the whole project si so intransparent) but they dont seem to have those problems :(
Hopefully chromium will figure this out fast... but those issues are open for a long time now and till now they dont got much attentione...

regards
B
19
S
7
G
1
Posts: 222
Reputation: 2,551

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 5 guests