virus on r148 ???

Chat about anything not covered in these forums, but keep it civil!

Post » Tue Oct 22, 2013 5:30 pm

@ashley i just downloaded the latest beta release and the second it finished the installation avg free said the .exe has a virus. is this legit?
https://www.dropbox.com/s/rre9crupc0t9xtk/Screenshot%202013-10-22%2019.24.12.png

https://www.dropbox.com/s/a3surn4j50tbmer/Screenshot%202013-10-22%2019.24.42.png
B
15
S
6
G
4
Posts: 277
Reputation: 3,948

Post » Tue Oct 22, 2013 10:13 pm

Nobody else has reported this so far, so it seems like a one-off false positive. The file should be digitally signed which ought to indicate to the antivirus that it's trustworthy, but I guess AVG has gotten over-suspicious in this case...
Scirra Founder
B
398
S
236
G
88
Posts: 24,441
Reputation: 194,661

Post » Tue Oct 22, 2013 11:46 pm

@asley. i guess avg is drunk! but i cant seem to get avg to let the .exe run.because it flags it as severe threat whatever i do i blocks it. i guess i have to uninstall it and try another antivirus.
B
15
S
6
G
4
Posts: 277
Reputation: 3,948

Post » Wed Oct 23, 2013 3:30 am

maybe it is indeed a virus? I know the official r148 is not infected, but maybe the file you have has been compromised.
Did you download from scirra.com? Is it possible it could have gotten infected somehow? Try submitting the exe to jotti to see if any other anti-viruses report it as infected.

That being said, AVG is really bad (second only to norton anti virus), so it's likely that it's just a false positive.Fimbul2013-10-23 03:31:55
B
36
S
8
G
8
Posts: 532
Reputation: 6,903

Post » Wed Oct 23, 2013 12:10 pm

Both the installer and Construct 2 executable files are digitally signed. If a virus had somehow infected them the digital signature would become invalid, which would probably throw some warning in Windows. So I doubt it really is infected at all, unless it got infected before we signed it, but that seems highly unlikely (I'm sure we'd have heard more about it!)
Scirra Founder
B
398
S
236
G
88
Posts: 24,441
Reputation: 194,661

Post » Wed Oct 23, 2013 1:38 pm

i installed r148 on my laptop running avg free and it detected nothing. i believe it either has to do that the desktop i had the alarm is an old pc running windows xp or the avg just freaked out and gave that warning.in either case the reason i reported it, is because i wanted to warn the developer in case for some strange reason avg had the exe blacklisted ,to send them an email letting them know they are mistaken and to fix that.
B
15
S
6
G
4
Posts: 277
Reputation: 3,948

Post » Wed Oct 23, 2013 7:15 pm

I just had the same thing happen. I installed 148 at home the other day and it was fine. I just installed it on another computer and got a virus found with AVG as "Heri".

Removed the threat and re-scanning now. I have never had a problem with AVG before. Odd. I did download from the Scirra website after googling releases.
"In truth we live, In Truth we die"
B
11
S
3
G
4
Posts: 22
Reputation: 3,177

Post » Wed Oct 23, 2013 8:47 pm

Looks like a false positive of course. Never a doubt! :)

http://virusscan.jotti.org/en/scanresult/ee683887482a52f2f6298527e3a6e4c87ef9fe87

AVG is the only AV that found anything with 23 different AVs searched.
"In truth we live, In Truth we die"
B
11
S
3
G
4
Posts: 22
Reputation: 3,177

Post » Wed Oct 23, 2013 9:37 pm

It really is worth paying for proper protection.

Even then, false positives are always a possibility, which is where sites such as Jotti are so useful.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
86
Posts: 5,422
Reputation: 59,530

Post » Thu Oct 24, 2013 10:24 pm

I have just had the same result with AVG - win32/heri
B
8
S
2
G
1
Posts: 45
Reputation: 1,007

Next

Return to Open Topic

Who is online

Users browsing this forum: No registered users and 4 guests