W7aacenc.exe has stopped working

Bugs will be moved here once resolved.

Post » Sat Jan 25, 2014 6:07 am

Link to .capx file (required! If link is blocked remove the http and www parts):
https://dl.dropboxusercontent.com/u/19421237/errorCapx.capx
(Audio file)
https://dl.dropboxusercontent.com/u/19421237/ExplosionMissile.wav

Steps to reproduce:
1. Try to import a sound into C2 with right click on the project folder

Observed result: Error indicating that W7aacenc.exe has stopped working. Audio file is not imported.

Expected result: Sound is imported successfully and no error is displayed

Browsers affected:
Chrome: N/A
Firefox: N/A
Internet Explorer: N/A

Operating system & service pack: Windows 8.1 Pro

Construct 2 version: 158.2 (64-bit)
    
B
8
S
3
G
1
Posts: 135
Reputation: 2,209

Post » Sat Jan 25, 2014 6:09 am

B
8
S
3
G
1
Posts: 135
Reputation: 2,209

Post » Mon Jan 27, 2014 1:19 pm

Can't reproduce, imports OK on Windows 8.1 here, but doesn't encode the .ogg variant. The .wav file has an unusual sample rate (11025 Hz), try upsampling it to 44.1k or something more common that the encoders might be able to deal with.
Scirra Founder
B
402
S
238
G
89
Posts: 24,628
Reputation: 196,023

Post » Mon Jan 27, 2014 1:43 pm

Happens to any... I will delete everything (re-installing didn't help) and try again. The rate for the other samples I have is 44.1

Thanks for looking into it.

B
8
S
3
G
1
Posts: 135
Reputation: 2,209

Post » Mon Jan 27, 2014 2:00 pm

It is still happening, with fresh installation
B
8
S
3
G
1
Posts: 135
Reputation: 2,209

Post » Mon Jan 27, 2014 2:02 pm

@Ashley Hi, is still happening with fresh installation and the sample rate requested. Any idea how to convert the file, none of my projects are now able to release with music.

How can I downgrade a Project? so I can use the version that worked?
Thanks
B
8
S
3
G
1
Posts: 135
Reputation: 2,209

Post » Mon Jan 27, 2014 3:46 pm

We haven't changed the encoder for a long, long time so even if you downgrade I assume it will work identically. Did you get Windows 8 N or one of the variants without media features? If so, it'll be missing the ability to encode AAC. You'll have to find your own encoder in that case, encode the .wavs yourself, then just import the .m4a files in to Construct 2.
Scirra Founder
B
402
S
238
G
89
Posts: 24,628
Reputation: 196,023

Post » Tue Jan 28, 2014 3:18 am

@Ashley thank you again! No, im just running Windows 8.1 Pro Full Version (not the N) Having imported the files AAC allowed me to submit my game with audio again... thanks!. Now, I will try to uninstall previous upgrades from other software, to try to determine what is breaking the AAC.
B
8
S
3
G
1
Posts: 135
Reputation: 2,209

Post » Tue Jan 27, 2015 10:08 am

Me too, today w7aacenc.exe doesn't work anymore.
B
13
S
4
G
1
Posts: 6
Reputation: 919

Post » Thu Jan 29, 2015 2:22 pm

W7aacenc.exe run a windows 7 compatibility, test on my computer, work fine.
Win 8.1
Construct 2 version: 195 (64-bit)
B
13
S
4
G
1
Posts: 6
Reputation: 919

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests