wasd controls bug

Bugs will be moved here once resolved.

Post » Thu Jul 30, 2015 6:36 pm

well, I am making a 2 players-plataform game, the game consists in shooting the other player. In the player 1 animations there is 1 for stay looking left without moving, but this doesnt reproduce when it has to do it.

Steps to Reproduce Bug
[list]
[*] Step 1 (event sheet) A is down: set anim animation "run left" and simulate controls left
[*] Step 2 (event sheet) A is released and is playing run relft: set animation "stay left"

Observed Result
when its runing left and I released A, the character doesnt reproduce the animation that I want, reproduce the character looking right.

Affected Browsers

[list]

opera: no

Construct 2 Version ID
free edition

ps: I checked the animations and the event sheet 100000 times and everything is perfect! :oops: :cry: :cry: :cry:
please help me :cry:
B
5
S
1
Posts: 1
Reputation: 543

Post » Thu Jul 30, 2015 6:59 pm

@Terremoto01

You haven't followed the bug reporting guidelines, and so this is likely to be closed automatically.

However, since this is your first post in using the free version, isn't it more likely that your events are incorrect, or are you seriously saying their is an actual bug in the C2 software?

Not saying it's not possible, just unlikely there is a bug, but impossible to say if you don't include your .capx, as required.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
86
Posts: 5,418
Reputation: 59,522

Post » Thu Aug 06, 2015 2:20 pm

Closing, please see the bug report requirements.
Scirra Founder
B
398
S
236
G
88
Posts: 24,428
Reputation: 194,600


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests