Water Fx Effect shows ugly pixels on mobile screen!

Report Construct 2 bugs here.

Post » Sun Jul 23, 2017 8:22 am

Water Fx Effect shows ugly pixels on mobile screen!
____ I cannot use single fx effect (water) on a background layer as when i export to apk it shows blurry seams (ugly pixels on mobile screen, in other words it is far different from smooth effect in preview(desktop))____

I made an example Capx for this bug report
____ https://drive.google.com/file/d/0B76HfQ9PM2BsTS1jWFFCY2JRdW8/view?usp=sharing____

Problem occurs after export in mobile device
____ Although this is not my game file but it simply contains a layer with water effect on it and when it is exported to apk (webview plus in my case) and please dont say cocoon is not officially supported because i am sure its not cocoon's fault , its simply because construct 2 do not have a solution for seam fixing!____

Steps to Reproduce Bug
  • Choose a layer
  • Add water fx effect on it
  • Export it to apk and run on a mobile device

Observed Result
____ Ugly pixels are visible on the layer____


Expected Result
____ Smooth water effect as is visible in desktop browser! ____
B
15
S
5
Posts: 79
Reputation: 1,206

Post » Mon Jul 24, 2017 11:43 am

please reply to this .......i have been dealing with this for a long time now, Please help!!!!
anyone?????????
B
15
S
5
Posts: 79
Reputation: 1,206

Post » Mon Jul 24, 2017 11:45 am

Can't i use one effect of my choice without any problem for a mobile game here?
i mean its already enough that i am dealing with performance issues due to effect use, but at least after all it should run smooth.
B
15
S
5
Posts: 79
Reputation: 1,206

Post » Mon Jul 24, 2017 11:54 am

shubhamrathi9 wrote:please reply to this .......i have been dealing with this for a long time now, Please help!!!!
anyone?????????


Please be patient: (from the Bug Report Requirements)

Why haven't you responded to my bug report yet?
We do look at every report, but developer and release schedules mean we may not get round to it immediately. Please allow a few weeks for it to be investigated. If you are waiting, you can improve the chance it is resolved when a developer does get round to it by carefully reviewing these guidelines and providing as much useful information about the problem as possible. If you are missing anything, you may end up waiting a few weeks for a reply simply asking for the missing information, and then you're waiting again.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
131
S
29
G
81
Posts: 5,328
Reputation: 56,630

Post » Mon Jul 24, 2017 12:19 pm

@zenox98
Okay i would wait!
and thanks for replying!
But please tell me if there is a workaround! (in case it is a bug and i will have to wait for new release to get it fixed)
Please
B
15
S
5
Posts: 79
Reputation: 1,206

Post » Tue Jul 25, 2017 6:16 am

@shubhamrathi9

I don't think this is a bug. Shader-effects have a huge impact on the fill rate and most mobil GPUs are to weak to handle that. I don't would use shader-effects on mobil games at all.
B
24
S
3
G
1
Posts: 451
Reputation: 2,165

Post » Tue Jul 25, 2017 7:46 am

@Asmodean
So thats it then, i cannot use a single shader effect for my mobile game! great !:p
B
15
S
5
Posts: 79
Reputation: 1,206

Post » Wed Jul 26, 2017 8:27 am

That's not the fault of construct or webGL. That how mobil GPUs are build. They are sharing the memory of the CPU and GPU and that can cause problems.

In general, you can assume that you will get performance close to native apps for the GPU side, as the WebGL graphics API uses your GPU for hardware accelerated rendering - there is just a little overhead for translating WebGL API calls and shaders to your OS graphics API (typically DirectX on Windows or OpenGL on Mac or Linux).

This is a snippet of the Unity3D Manual. :)
B
24
S
3
G
1
Posts: 451
Reputation: 2,165


Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests