Web game update problem

Discussion and feedback on Construct 2

Post » Mon Dec 07, 2015 8:32 pm

Hey fellow constructers!

Sometimes when I update my web game the sprites images that was changed and updated are sometimes obscure and didn't change at all. They are the same old sprites but cut and odd.

Tried reproducing this but it happens from time to time inconsistently.

What causes this?

Tried on my girlfriend's Mac and Samsung - everything was updated well (yes, the game was cached before).

It happens on my PC and Sony phone (i both use them for C2 game previewing)

Could it be that the images caches from the preview version of the game and the hosted web version together and causes some cache troubles?

*Used Chrome in all scenarios
Positive, inspiring and jazzy games!



www.crystalgames.space



Enjoy!
B
17
S
8
G
3
Posts: 173
Reputation: 3,453

Post » Mon Dec 07, 2015 9:36 pm

Renaming the sprite that's being updated or creating a new one and putting in the old sprite's place should resolve this problem :)
Positive, inspiring and jazzy games!



www.crystalgames.space



Enjoy!
B
17
S
8
G
3
Posts: 173
Reputation: 3,453

Post » Wed Dec 09, 2015 4:58 am

That's exactly it, the way Chrome manages cache will do that. I usually just spam the F5 key or Ctrl F5.

Just googled it to give you a better answer and found this - you can press F12 to open up the devtools, then right-click the refresh icon and pick "erase cache and refresh" or something along those lines.
B
121
S
41
G
40
Posts: 841
Reputation: 27,857

Post » Wed Dec 09, 2015 6:42 pm

Thanks andreryin!

Relief :)
Positive, inspiring and jazzy games!



www.crystalgames.space



Enjoy!
B
17
S
8
G
3
Posts: 173
Reputation: 3,453


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 7 guests