WebGL blurring

Discussion and feedback on Construct 2

Post » Sat May 12, 2012 10:13 am

When I disable webGL - my pixelart graphics are ok, but when I enable webGL - all graphics are blurred (despite I'm not scaling anything).

Disabled WebGL:


Enabled WebGL:
B
53
S
14
G
10
Posts: 282
Reputation: 7,578

Post » Sat May 12, 2012 10:19 am

I don't really see a difference.

Maybe try to tweak the sampling property in the project properties ?Kyatric2012-05-12 10:27:30
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Sat May 12, 2012 10:23 am

I remember reading that if it's a tiled background, the size has to be a multiple of 2 otherwise it will blur in WebGL. Also, try changing the sampling from linear to point, although this might make other things look slightly worse from what I saw.

Also, make sure the zoom is 100% on the browser.Xavier2012-05-12 10:25:34
B
63
S
23
G
17
Posts: 254
Reputation: 14,342

Post » Sat May 12, 2012 12:13 pm

Press Ctrl+0 to get default zoom on the browser.
B
96
S
25
G
20
Posts: 3,055
Reputation: 22,644

Post » Sat May 12, 2012 1:23 pm

pixel rounding - set to yes
B
81
S
50
G
10
Posts: 555
Reputation: 13,009

Post » Sat May 12, 2012 2:23 pm

Try also setting 'Point' sampling in Project Properties.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Mon May 14, 2012 3:42 pm

It's on now. Thank You for your help.
B
53
S
14
G
10
Posts: 282
Reputation: 7,578


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 7 guests