WebGL blurring

Discussion and feedback on Construct 2

Post » Sat May 12, 2012 10:13 am

When I disable webGL - my pixelart graphics are ok, but when I enable webGL - all graphics are blurred (despite I'm not scaling anything).

Disabled WebGL:


Enabled WebGL:
B
55
S
14
G
10
Posts: 287
Reputation: 7,677

Post » Sat May 12, 2012 10:19 am

I don't really see a difference.

Maybe try to tweak the sampling property in the project properties ?Kyatric2012-05-12 10:27:30
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
271
S
99
G
70
Posts: 7,267
Reputation: 75,769

Post » Sat May 12, 2012 10:23 am

I remember reading that if it's a tiled background, the size has to be a multiple of 2 otherwise it will blur in WebGL. Also, try changing the sampling from linear to point, although this might make other things look slightly worse from what I saw.

Also, make sure the zoom is 100% on the browser.Xavier2012-05-12 10:25:34
B
72
S
27
G
17
Posts: 254
Reputation: 14,971

Post » Sat May 12, 2012 12:13 pm

Press Ctrl+0 to get default zoom on the browser.
B
96
S
34
G
29
Posts: 3,138
Reputation: 28,234

Post » Sat May 12, 2012 1:23 pm

pixel rounding - set to yes
B
81
S
50
G
11
Posts: 555
Reputation: 13,569

Post » Sat May 12, 2012 2:23 pm

Try also setting 'Point' sampling in Project Properties.
Scirra Founder
B
382
S
223
G
86
Posts: 23,994
Reputation: 189,755

Post » Mon May 14, 2012 3:42 pm

It's on now. Thank You for your help.
B
55
S
14
G
10
Posts: 287
Reputation: 7,677


Return to Construct 2 General

Who is online

Users browsing this forum: Darknessed, greenleafvt and 3 guests