WebGL + Chrome = broken webfonts?

Discussion and feedback on Construct 2

Post » Mon May 27, 2013 4:12 pm

@Dave Hailwood, @Thndr, thanks for the tips. I'll give it another go and see if I can get it working a bit smoother
B
13
S
4
Posts: 127
Reputation: 1,479

Post » Tue May 28, 2013 11:47 pm

OK, so building on all the excellent tips from the guys above, I have done a few hours of testing. I tried a load of different combinations, and I have found one that seems to work.

So in summary I have managed to get Webfonts to work on Chrome with WebGL and with the pop-in suitably hidden. It seems to work perfectly for me, I have tested with 3 different textbox objects and 5 different instances of each, all on screen at once. I would appreciate some others testing this same method, to see if it's just working on my machine/setup etc.

I would also like to reiterate that this is all stuff already suggested by @Paradox, @Dave Hailwood, @Thndr etc. But I just wanted to share that I put it all together and got it to work how I wanted, maybe it might help somebody else as fussy as me:



Textbox1 [On Created]:

     > Textbox1: Set Invisible
     > Textbox1: Set Font Size to 0
     > Textbox1: Set Web Font 'Font_Name' from 'Stylesheet.css'
     > System: Wait 0.6 Seconds
     > Textbox1: Set Web Font 'Font_Name' from 'Stylesheet.css'
     > Textbox1: Set Visible
     > System: Wait 0.6 Seconds
     > Textbox1: Set Font Size to 12


(Be sure to use 'On Created', as this is called before 'Start of Layout'. This is all tested with local embedded Webfonts too.)
B
13
S
4
Posts: 127
Reputation: 1,479

Post » Wed May 29, 2013 8:41 pm

@seconddimension

I'll give your method a test on Friday; I'm still experimenting with methods, as what I've found so far is although some attempts work fine in the preview mode on all browsers and on my ipad, as soon as I export to Dropbox I get some pop in on some browsers. I've also been experimenting with setting the colour of the font to same as background colour and having it visible (so it still can't be seen, but has time to get past the pop in without anyone seeing it) and then setting it to a visible colour after half a second.

We'll find a good workaround eventually!
B
12
S
3
G
1
Posts: 235
Reputation: 2,053

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: Yahoo [Bot] and 16 guests

cron