WebGL effects malfunctioning in Firefox?

Discussion and feedback on Construct 2

Post » Mon Jan 19, 2015 9:37 pm

Hi. I just started encountering a weird problem in Firefox preview where the screen will just completely black out. I managed to track it down to WebGL effects (Inverse and Contrast). These effects works as intended in chrome and node webkit, but they black out the screen in Firefox. Am I alone with this problem? It doesn't appear to happen with all effects however. AdjustHSL works just fine on all platforms for instance, which really confuses me.

Thanks
B
35
S
10
Posts: 390
Reputation: 3,278

Post » Mon Jan 19, 2015 10:11 pm

Me too, but i don't have any WebGl effects (Since the last steam update)!
Playable games:
http://jamesxxxyz.newgrounds.com/
Newest: Blue and red arrows
Latest update: Blue and red arrows

What you want in C3?
viewtopic.php?f=146&t=122050

Youtube: https://www.youtube.com/channel/UCLE7Ml ... /playlists
B
11
S
4
Posts: 281
Reputation: 1,543

Post » Tue Jan 20, 2015 2:03 pm

If it works in Chrome it suggests a problem with Firefox. Are your graphics drivers up to date?
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143

Post » Tue Jan 20, 2015 3:07 pm

Yes latest one. Games with only one eventsheet and layout works.
Playable games:
http://jamesxxxyz.newgrounds.com/
Newest: Blue and red arrows
Latest update: Blue and red arrows

What you want in C3?
viewtopic.php?f=146&t=122050

Youtube: https://www.youtube.com/channel/UCLE7Ml ... /playlists
B
11
S
4
Posts: 281
Reputation: 1,543

Post » Tue Jan 20, 2015 3:40 pm

I use firefox all the time, so can either of you post a simple .capx that is broken so I and others can also test? Will either prove/disprove if Firefox bug or driver bug.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,556
Reputation: 60,456

Post » Tue Jan 20, 2015 4:30 pm

I had this problem either, but tought it was my firefox and changed to preview with Chrome.
My firefox was not clearing the background too.
B
18
S
4
G
1
Posts: 143
Reputation: 1,868

Post » Wed Jan 21, 2015 7:25 am

@frcol
You tried to export your game and upload it. When you wanna play this game in a Firefox browser and the screen is black, than it is a real problem. I exported it and when i started screen is black. I didn't upload it but earlier it works.
Playable games:
http://jamesxxxyz.newgrounds.com/
Newest: Blue and red arrows
Latest update: Blue and red arrows

What you want in C3?
viewtopic.php?f=146&t=122050

Youtube: https://www.youtube.com/channel/UCLE7Ml ... /playlists
B
11
S
4
Posts: 281
Reputation: 1,543

Post » Wed Jan 21, 2015 4:48 pm

I'm currently having WebGL problems too, it's since the Firefox 35 update. I'm sure about that since I did not touch the game at all and from one day to another, suddenly the shader effects were quite problematic.

Took me some time to figure out it's acutally Firefox.

Everything's fine in Chrome, so..
B
5
S
1
Posts: 33
Reputation: 462

Post » Wed Jan 21, 2015 9:18 pm

@dhoeke
Before Firefox was updated, my steamversion was updated that's why it could be the c2 update too. You tried to upload something and checked it out with Firefox?
Playable games:
http://jamesxxxyz.newgrounds.com/
Newest: Blue and red arrows
Latest update: Blue and red arrows

What you want in C3?
viewtopic.php?f=146&t=122050

Youtube: https://www.youtube.com/channel/UCLE7Ml ... /playlists
B
11
S
4
Posts: 281
Reputation: 1,543

Post » Wed Jan 21, 2015 10:01 pm

Yep, it's Firefox 35.
As mentioned:

I'm sure about that since I did not touch the game at all and from one day to another, suddenly the shader effects were quite problematic.


In my case, light objects (WebGL Destination Out effect) did not use the blend effect anymore and some transparent glas objects were overall just strange, white glowing boxes. And I did not touch any of these objects. What's why I was looking for what I had done wrong for about two hours until I realized the only software that changed was Firefox browser, it updated. And since everything works fine in Chrome, you can be sure it's Firefox. Very annoying.

(And, also, people not using C2 are having problems with WebGL from what I get on Twitter.)
B
5
S
1
Posts: 33
Reputation: 462


Return to Construct 2 General

Who is online

Users browsing this forum: AppStar and 7 guests