WebGL on - objects disappear in the editor

Bugs will be moved here once resolved.

Post » Sun May 25, 2014 4:45 pm

Problem Description
I have a demo capx which is reduced from a game I am working on. When the capx is opened all objects on the layout are visible; however, scrolling left or right or zooming in and out on the layout causes most of the objects to disappear - and the ones that remain visible cannot then be selected using the mouse. The only subsequent way to see these missing objects is to deselect WebGL.

Attach a Capx
webgl not visible in editor.capx


Description of Capx
The capx contains a few objects and a family containing some of these objects.

Steps to Reproduce Bug
  • Zoom in and out on the layout using ctrl + mouse-wheel
  • Alternatively - scroll left or right by dragging a scroll bar in the editor

Observed Result
After a short period of scrolling or zooming, most of the objects in the editor can be seen to disappear and none of the remaining objects can be selected in the layout editor. Deleting some of the objects or the Family sometimes rectifies this fault.

Expected Result
The objects should always be visible in the editor.

Affected Browsers
  • N/A - this bug appears in the editor.

Operating System and Service Pack
Tested and reproduced on W8.1 x64 and W7 SP1 x64.

Construct 2 Version ID
r170
You do not have the required permissions to view the files attached to this post.
Last edited by Colludium on Tue May 27, 2014 11:53 pm, edited 2 times in total.
A big fan of JavaScript.
B
76
S
20
G
76
Posts: 2,286
Reputation: 47,556

Post » Sun May 25, 2014 5:00 pm

You are using SpriteFont+ plugin, can you remove it and post your file again?
If I think right it might be released to this bug
https://www.scirra.com/forum/spritefont-tint-stretched-text-in-layout-view_t105820
where using webgl effects make sometimes random objects displace or vanish from editor.
ImageImageImageImage
B
158
S
67
G
43
Posts: 2,603
Reputation: 36,003

Post » Sun May 25, 2014 5:08 pm

@shinkan, I think you could be right. If I delete the SpriteFont+ object from the original project then the fault immediately disappears.
A big fan of JavaScript.
B
76
S
20
G
76
Posts: 2,286
Reputation: 47,556

Post » Sun May 25, 2014 5:14 pm

Oh. that's nice... I mean, not nice at all but, this proves that there is something wrong with WebGL and editor. Cause same thing (object displacement, display issue) happens for mr with SpriteFont, Sprite, TiledBG, 9patch and now SpriteFont+
ImageImageImageImage
B
158
S
67
G
43
Posts: 2,603
Reputation: 36,003

Post » Sun May 25, 2014 6:53 pm

It's a weird one - if I delete the Family or the SpriteFont+ object then the problem goes away - but the SpriteFont+ object is not part of the Family...
A big fan of JavaScript.
B
76
S
20
G
76
Posts: 2,286
Reputation: 47,556

Post » Mon Jun 02, 2014 3:19 pm

Closing, we cannot accept bug reports based on third party plugins.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 6 guests