WebSocket

Get help using Construct 2

Post » Fri Apr 19, 2013 12:34 pm

@DragonDrumstick - oops, you're right, fixed for the next build. In future it's best to make a full post in the Bugs forum, because I will definitely find it there, instead of coming across a bug by chance in the 'How do I' forum!
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,528

Post » Mon Apr 29, 2013 10:58 pm

@Ashley

I am faced with a websocket problem, too;

When I try to connect the websocket-server, an error comes up:
"Assertion failure: Calling expvalue.set_string without string type"
and connection failed.

But the websocket-server have no problems, since I can connect to it with a HTML page.

My websocket connection action is as follows:
URL: "ws//:xxxx.xxxx.xxxx.xxxx"(my ip address)
Protocol(optional):"10000"

Can you help me with it? My C2 version is r125
Thank you in advance!
B
5
Posts: 21
Reputation: 498

Post » Mon Apr 29, 2013 11:22 pm

@rexrainbow

I am faced with a websocket problem, too;

When I try to connect the websocket-server, an error comes up:
"Assertion failure: Calling expvalue.set_string without string type"
and connection failed.

But the websocket-server have no problems, since I can connect to it with a HTML page.

My websocket connection action is as follows:
URL: "ws//:xxxx.xxxx.xxxx.xxxx"(my ip address)
Protocol(optional):"10000"

Can you help me with it? My C2 version is r125
Thank you in advance!
B
5
Posts: 21
Reputation: 498

Post » Tue Apr 30, 2013 2:18 pm

@MelonGuns - please post a full bug report in the bugs forum, otherwise it's hard to fix it.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,528

Post » Wed May 01, 2013 6:06 pm

@Ashley

Ok, the exception is as follows:

----------------------------------------------------------------------------------
Assertion failure: Calling expvalue.set_string without string type

Stack trace:
assert2@http://localhost:50000/preview_prelude.js:12
ExpValue.prototype.set_string@http://localhost:50000/expressions.js:778
Exps.prototype.ErrorMsg@http://localhost:50000/C2WebSocket_plugin.js:172
ExpNode.prototype.eval_object_behavior_exp@http://localhost:50000/expressions.js:319
ExpNode.prototype.eval_and@http://localhost:50000/expressions.js:550
Parameter.prototype.get_exp@http://localhost:50000/eveng.js:1464
Action.prototype.run_object@http://localhost:50000/eveng.js:1277
EventBlock.prototype.run_actions_and_subevents@http://localhost:50000/eveng.js:694
EventBlock.prototype.run@http://localhost:50000/eveng.js:662
Runtime.prototype.executeSingleTrigger@http://localhost:50000/preview.js:3186
Runtime.prototype.triggerOnSheetForTypeName@http://localhost:50000/preview.js:3105
Runtime.prototype.triggerOnSheet@http://localhost:50000/preview.js:3038
Runtime.prototype.trigger@http://localhost:50000/preview.js:3002
@http://localhost:50000/C2WebSocket_plugin.js:134
----------------------------------------------------------------------------------

Do you have any idea?
My ws server is 127.0.0.1:8080
So My ws connect to phrase is :
URL :"ws://127.0.0.1"
protocol: "8080"
B
5
Posts: 21
Reputation: 498

Post » Wed May 01, 2013 6:27 pm

@MelonGuns: How to report bugs (in the Bugs forums)

Thank you.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791

Previous

Return to How do I....?

Who is online

Users browsing this forum: No registered users and 19 guests