Webstorage problem

Get help using Construct 2

Post » Sat Jun 01, 2013 4:59 pm

Hi,

i have always problem with Webstorage... all work good in construct 2 but when i export it as HTML5 website or smiliar, webstorage does not work... NodeJS and CocoonJS work, but in browser after export no.... I test in in my computer and on web hosting too... here is my game if you want to see it: buildasnowman.raiper34.net

Please fast help me :(
B
25
S
4
G
2
Posts: 318
Reputation: 2,501

Post » Sat Jun 01, 2013 5:44 pm

Check your browser security settings. You may not be allowing the game to save data locally.
B
56
S
15
G
13
Posts: 826
Reputation: 17,675

Post » Sun Jul 14, 2013 1:15 pm

[QUOTE=Tekniko] Check your browser security settings. You may not be allowing the game to save data locally.[/QUOTE]

Is it the "cookies" on the device the only setting that needs to be enabled? Or is there another setting.     
And, where do you access those settings, for example, on a cell phone: Is it just through the browser (chrome, explorer)?

because I did all that, and still my storage value remains = 0.    Which I'm assuming is NaN if I take out my "int".

tekniko- I love the picture. That's how my IT guy at work wants to reply often.    Squirrely12013-07-14 13:18:25
B
16
S
2
G
1
Posts: 35
Reputation: 1,033

Post » Sun Jul 14, 2013 2:53 pm

Did you make event when storage does not exist then set storage set 0 for exmple? Or something smiliar... I will see it, i am not home now... It helped for me
B
25
S
4
G
2
Posts: 318
Reputation: 2,501

Post » Tue Jul 16, 2013 12:12 am

[QUOTE=Raiper341] Did you make event when storage does not exist then set storage set 0 for exmple? Or something smiliar... I will see it, i am not home now... It helped for me[/QUOTE]

   The concept of "key does not yet exist" was bugging me but all the examples the forum worked on my PC and I can't figure what to do on a device.      I would love to hear what you know.
any info would help. TY TY

EdSquirrely12013-07-17 03:50:16
B
16
S
2
G
1
Posts: 35
Reputation: 1,033

Post » Wed Jul 17, 2013 3:53 pm

Raiper,
It worked!!!!!!!!!!!!!!!!!!!!
Thanks for the direction.
B
16
S
2
G
1
Posts: 35
Reputation: 1,033


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 13 guests