Weird bugs in a capx, dont run in chrome and firefox

Bugs will be moved here once resolved.

Post » Mon May 22, 2017 3:07 pm

Problem Description
This project present different strange problems I can not fix or even identify:
-No able to open in Chrome or Firefox, just explorer or NW.js (Just with this capx, I tried others and works perfectly )
-Can not use (number*loopindex) in loops. Events never happen. (in others capx works perfectly ))
-First instance of a object (enemy) in the layer “stage1” gets weird value (posX), like type1_front1 gets weird values at “spawnLeft” from his family. This not happen in the next instances. (Event sheets "weapons and enemies", line 8)

Every firt instance of the family “enemies” have some error in their variables when are created.

Attach a Capx
https://www.dropbox.com/s/qn8w6vpemdqvwfs/version_0.0.1.3.capx?dl=0

Description of Capx
Spawn diferent instances of enemies in order.

Steps to Reproduce Bug
  • Run layout "stage1" with chrome or firefox
  • Try to do a "repeat loop" with 0.5*loopindex
  • Oberve the values in posX in the first intance of "type1_front1"

Observed Result
____

Expected Result
Run normally

Affected Browsers
  • Chrome: (YES)
  • FireFox: (YES)
  • Internet Explorer: (NO)

Operating System and Service Pack
Windows 10

Construct 2 Version ID
244
B
21
S
3
Posts: 77
Reputation: 1,112

Post » Thu Jun 22, 2017 3:50 pm

Closing, please see the bug report guidelines. The project has well over 100 events so it could easily be a mistake in your own events. The steps to produce a minimal project are to prove the problem is in Construct 2.
Scirra Founder
B
395
S
232
G
88
Posts: 24,368
Reputation: 193,746


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests