Weird shooting origin

Get help using Construct 2

Post » Thu Jun 27, 2013 8:19 pm

Hi!

I dont know if this has been asked but right now i have some very odd shooting position. I added new imagepoint for player specifically for shooting and it dosnt really work as i thought it would - pressing a button spawns a bullet in 2 random places.



Also how do i attach capx?
B
2
Posts: 5
Reputation: 160

Post » Thu Jun 27, 2013 10:15 pm

Create your dropbox account and upload your .capx
B
99
S
35
G
29
Posts: 3,139
Reputation: 28,421

Post » Fri Jun 28, 2013 12:46 pm

Try system condition Create object and set it to players position. Work fine for me.

I tried your 'code', and it works too. Show us you capx pleaseMagicTofu2013-06-28 12:51:58
B
13
S
6
G
3
Posts: 20
Reputation: 4,131

Post » Fri Jun 28, 2013 7:31 pm

You chose "set angle" for your bullet. Try "set angle of motion", I think that should fix your problem.retrodude2013-06-28 19:31:56
B
18
S
4
G
3
Posts: 436
Reputation: 4,801

Post » Fri Jun 28, 2013 7:48 pm

Setting angle motion dosnt help.

Here is the link to the https://www.dropbox.com/s/qwuqin8ev82wz1k/scb.capx
B
2
Posts: 5
Reputation: 160

Post » Fri Jun 28, 2013 9:08 pm

Two problems:

1. The coordinates of image point 1 on the player object are way off (-110,-270). Moving the image point in front of the player should fix this.

2. You're spawning the bullets on layer 0, which has a parallax of "50,50". Changing the parallax of that layer to "100,100", or spawning the bullets on layer 1 should fix this.


I made those changes, and the bullets fired correctly.
B
63
S
19
G
8
Posts: 341
Reputation: 12,130

Post » Fri Jun 28, 2013 10:31 pm

Thanks! This helped!
B
2
Posts: 5
Reputation: 160


Return to How do I....?

Who is online

Users browsing this forum: R0J0hound, volumetv and 16 guests